Page MenuHomePhabricator

ERR<1603>:evas-gl_x11 modules/evas/engines/gl_x11/evas_engine.c:2629 eng_image_native_set() eglCreateImage() for Pixmap 0x41f6bd failed: 0x3003
Closed, DuplicatePublic

Description

I'm using enlightenment-0.21.3-1 in archlinux. I have a lot of these error in my .Xsession, with the following stack trace:

                                   /usr/lib/libeina.so.1  | ??/?? : 0 @ eina_log_print_cb_journald()
                                   /usr/lib/libeina.so.1  | ??/?? : 0 @ eina_log_print_cb_stdout()
                                   /usr/lib/libeina.so.1  | ??/?? : 0 @ eina_log_print()
/usr/lib/evas/modules/engines/gl_x11/v-1.18/module.so     |   /   : 0 @ ()
                                   /usr/lib/libevas.so.1  | ??/?? : 0 @ efl_canvas_image_internal_class_get()
                                   /usr/bin/enlightenment | ??/?? : 0 @ e_comp_object_native_surface_set()
                                   /usr/bin/enlightenment | ??/?? : 0 @ e_comp_object_dirty()
                                   /usr/bin/enlightenment | ??/?? : 0 @ e_comp_shape_queue_block()
                                   /usr/lib/libecore.so.1 | ??/?? : 0 @ ecore_idler_del()
                                   /usr/lib/libecore.so.1 | ??/?? : 0 @ ecore_event_add()
                                   /usr/lib/libecore.so.1 | ??/?? : 0 @ ecore_main_fd_handler_add()
                                   /usr/lib/libecore.so.1 | ??/?? : 0 @ ecore_main_loop_begin()
                                   /usr/bin/enlightenment |   /   : 0 @ ()
                                   /usr/lib/libc.so.6     | ??/?? : 0 @ __libc_start_main()
                                   /usr/bin/enlightenment | ??/?? : 0 @ _start()

I don't think it leads to crash, but sometime E does crash to the point where I need to log back to my graphical session.
Hope it helps,