Page MenuHomePhabricator

EFL 1.20.0 beta 2 & EFM 0.21.8 file properties and folder preview windows is the wrong size.
Closed, ResolvedPublic

Description

The file properties and folder preview windows comes up skinny:

AJSlye created this task.Jul 7 2017, 7:20 PM
AJSlye updated the task description. (Show Details)
AJSlye renamed this task from EFL 1.20.0 beta 2 & EFM Preview window the wrong size to EFL 1.20.0 beta 2 & EFM 0.21.8 Preview window is the wrong size..Jul 7 2017, 7:22 PM
simotek triaged this task as High priority.Jul 18 2017, 5:25 PM
simotek added a project: efl.
simotek added a subscriber: simotek.
simotek added a subscriber: stefan_schmidt.
AJSlye renamed this task from EFL 1.20.0 beta 2 & EFM 0.21.8 Preview window is the wrong size. to EFL 1.20.0 beta 2 & EFM 0.21.8 file properties window is the wrong size..Jul 18 2017, 5:26 PM
AJSlye raised the priority of this task from High to Incoming Queue.
AJSlye updated the task description. (Show Details)
simotek triaged this task as High priority.Jul 18 2017, 5:27 PM

This seems to be a regression from 1.19

AJSlye updated the task description. (Show Details)Jul 18 2017, 5:33 PM
AJSlye renamed this task from EFL 1.20.0 beta 2 & EFM 0.21.8 file properties window is the wrong size. to EFL 1.20.0 beta 2 & EFM 0.21.8 file properties and folder preview windows is the wrong size..Jul 18 2017, 5:35 PM
AJSlye updated the task description. (Show Details)
ProhtMeyhet lowered the priority of this task from High to Pending on user input.Jul 20 2017, 2:34 PM
ProhtMeyhet added a subscriber: ProhtMeyhet.

looks like T5548, so it maybe is resolved in git.

ProhtMeyhet raised the priority of this task from Pending on user input to High.Jul 20 2017, 2:42 PM
ProhtMeyhet added a subscriber: netstar.

ok, no it's not resolved apparently. in T5649 @netstar reports the same. (resetting priority)

raster added a subscriber: raster.Jul 20 2017, 8:14 PM

yup. not resolved.

Partly resolved and committed. There is still an issue with the popup preview due to e_widget_table.c issues. File Properties is fixed in git master.

D5095 has not been merged yet...

OK, then the first issue's fix has already been merged in E master, but not the fix for the second issue?

This comment was removed by AJSlye.

T'was a bit confusing, they were two separate issues with similar causes.

@AJSlye @ProhtMeyhet maybe you could try using the small patch at https://phab.enlightenment.org/D5095

Here is the link for the patch: https://phab.enlightenment.org/D5095?download=true

and confirm this works with the hover-over folder preview.

n0p513d added a subscriber: n0p513d.EditedAug 16 2017, 3:15 AM

I just tried the patch above on efl-1.20.2 and enlightenment-0.21.9 and its not as skinny but not back to full width. Am I missing a another patch not merged in the versions I've mentioned?
https://www.enlightenment.org/ss/display.php?image=e-59941fd3b6c785.60993439.jpg

no...do you recall full-width size before? it's been so long i cannot remember how it was :/

This started for me after last but one efl version upgrade (0.21.8). Was like the screenshot above. https://www.enlightenment.org/ss/e-59906702abc759.00929274.jpg

It definitely wasn;t like that for the directory listing popup.

As far as I can remember it was pretty-close to :

https://www.enlightenment.org/ss/display.php?image=e-599030ca3875f5.56736643.jpg

just a small preview...

netstar added a subscriber: zmike.Aug 16 2017, 3:57 AM

Maybe @zmike can clarify for us all.

Thanks for trying the patch out btw.

Just for clarification, this shot https://www.enlightenment.org/ss/e-59906702abc759.00929274.jpg was how it used to be, then went to https://www.enlightenment.org/ss/display.php?image=e-599030ca3875f5.56736643.jpg after efl upgrade, now, after patch looks like https://www.enlightenment.org/ss/display.php?image=e-59941fd3b6c785.60993439.jpg Pretty much the same though before patch was even skinnier for me.

Let's close this ticket it's too messy. One part is fixed, there's too much confusion in this ticket. See:

https://phab.enlightenment.org/T5891

netstar closed this task as Resolved.Aug 16 2017, 5:34 AM
netstar claimed this task.

Just to clarify finally, this (like my own ticket) should have been two tickets. Although both issues are related they are not the same.