Page MenuHomePhabricator

Corrupt render of evas mapped objects
Closed, ResolvedPublic

Description

https://www.enlightenment.org/ss/e-596d19949bc316.82108545.jpg
https://www.enlightenment.org/ss/display.php?image=e-596d18d3e8de89.72089021.jpg
https://www.enlightenment.org/ss/display.php?image=e-596d17ca75a807.24352215.jpg

The last one is subtle - the damage is above the currently active menu and almost faded out. The first one is my masterpiece. :)
I'm seeing these with the drm engine.

Spent some time trying to figure out what's up with this, and it turns out this didn't happen until efl commit 470478030 which is the commit that closed T4904. If I disable the shortcut added in that commit I can't see the problem anymore. Hopefully it's not just an insane timing issue that the optimization tickled.

Only visible in software render, doesn't happen with ECORE_EVAS_FORCE_SYNC_RENDER=1
I usually only notice it when moving between heavily populated menu items when he menu is over a bright window, so that's probably how it's gone so long undetected.

ManMower created this task.Jul 17 2017, 1:27 PM

Caught this out of the corner of my eye again today. Adding some more subscribers since it's a regression and probably warrants some attention.

Simply reverting is a potential fix, but the result is frame drops under rpi when using menus (see T4904) so I don't want to just blindly do that if there are other options.

ManMower closed this task as Resolved.Jan 4 2018, 9:06 AM

I've just rebuilt efl+e git and spent a not insignificant amount of time trying to catch a badly rendered frame. I guess I'm jumping at shadows because this seems like it may actually be gone now.

closing with no relevant commit...

raster added a comment.Jan 4 2018, 9:18 PM

Sorry - I didn't look more into it due to it being so hard to reproduce and there being other things to work on... :(

Yeah, it was (is?) really elusive, and just looks like a bit of a sparkle when the menu changes, so I thought I was seeing it now when I was actually seeing texture filtering artifacts on the zoom. When I actually started trying to freeze a frame of it now I couldn't.

I don't see how the original patch could've introduced the problem, my best guess is that some of cedric's timing fixes late last year resolved it.

I'll keep an eye out in case it comes back. :)

raster added a comment.Jan 7 2018, 9:32 PM

if it was the timing fixes ... then the "patch that created it" indeed would be mysterious in that "you can't see how it created the bug" because all it did was change timing (in a legitimate way)... but yeah. heisenbugs - or the "rare and hard to reproduce are a major pain indeed. unfortunately they just trickle to the bottom of the pile :(