Page MenuHomePhabricator

Telegram desktop graphics glitch
Closed, ResolvedPublic

Description

Telegram desktop client works normally.

But when I right click on any message to get a right click menu (which contains reply, delete and other options), it flashes and goes away before I can even click.
Long click doesn't work and nothing makes that menu to stay.

This only happens in enlightenment DE.

System specs
AMD A4-3305M APU
AMD HD6480G GPU
:: Software ::
xf86-video-ati drivers (v 7.9.0)
Archlinux (Kernel 4.11.7)
Enlightenment E21 -git
EFL -git

OhYash created this task.Jul 27 2017, 5:13 AM
bu5hm4n added a subscriber: bu5hm4n.
zmike added a comment.Jul 28 2017, 6:53 AM

Looked into this, but I'm not a user of telegram and it's a bit of a pain to set up. It's Qt-based, so I'd suggest trying to find another app with similar behavior.

zmike lowered the priority of this task from Normal to Pending on user input.Jul 28 2017, 6:53 AM
OhYash added a comment.EditedJul 30 2017, 10:04 AM

Can't find any other app with same problem. (Can't say it's get telegram specific too, I've just tried very few apps)

But I guess this is where the right click menu gets called -> link.
(around the line, and I guess of that, because those "reply", "edit" options show up in it.)

Maybe there's any other e's graphics developer who also uses telegram. Ticket could be assigned to them.

OhYash added a comment.EditedMar 14 2018, 12:14 PM

Update: The problem is same in WPS office presentation (Fullscreen presentation mode).
The right click menu flashes and vanishes away.

Except that in WPS Office, the menu shows up eventually after 2~3 seconds.

Personally, I've not seen this problem since moving to Telegram Desktop 1.2.17. Obviously, this doesn't mean that there isn't something that Enlightenment reacts to in an unusual manner, but it would be interesting to hear if @OhYash sees the same, or if I've inadvertently changed something in either Telegram or Enlightenment that caused this problem to stop manifesting itself.

Ah, no, it's started happening again. So it looks like it's an intermittent problem. They're always the best sort!

Right click menu starts working after fullscreen image preview. Can use this as bypass solution before bug will be fixed.

problem still present: Right click not working

Offray added a subscriber: Offray.Mar 27 2019, 9:50 AM

I can confirm this behavior is still present, which makes the desktop client pretty useless for nested conversations and messages resend.

My system is a Manjaro rolling release (updated on March 26) running E 0.22.4-1.

This is still relevant.
Telegram 1.7.7
E 0.22.3

Still present...
E 0.22.4
Slackware current
Graphics card: Nvidia GT710 with propietary driver
Telegram 1.7.14

Context menus are working fine since 0.23.x. (Greatly appreciated.)

RCalixte closed this task as Resolved.Oct 13 2019, 10:52 PM