Page MenuHomePhabricator

efl upgrading through efler
Closed, InvalidPublic

Description

Hi All,

I am upgrading efl through efler and i observed the following. EFL runs through cmake and at the end I get an alert


efl 1.20.0-beta1

Configuration...: profile=release os=darwin16.7.0

EFL API Set...: both
CPU Extensions: x86_64 (+mmx +sse3)
System Feature: coroutine=setjmp +ipv6
Threads.......: POSIX (+spinlocks -barrier -affinity -setname +__thread)
Cryptography..: openssl
X11...........: none
OpenGL........: full 
C++11.........: yes
JavaScript....: none
JavaScript flg:

Eina............: yes (systemd-journal= unwind=yes)
Eo..............: yes (eo-id=)
Eolian..........: yes (+cxx)
Emile...........: yes (crypto=openssl)
Eet.............: yes
Evas............: yes (-lua-old +fontconfig +fribidi -harfbuzz -cserve -tile-rotate dither-mask=big -hyphen)

Engines.......: buffer=static -fb -psl1ght +gl-cocoa -gl-sdl -software-gdi -software-ddraw -wayland-egl -wayland-shm -drm -gl-drm -eglfs -software-xlib -gl-xlib
Vg Loaders    : svg=static eet=static
Image Loaders.: bmp=static eet=static generic=static +gif ico=static jpeg=static -jp2k pmaps=static png=static psd=static tga=static +tiff wbmp=static -webp xpm=static tgv=static dds=static +poppler +spectre +raw +rsvg +xcf

Ecore...........: yes (systemd-daemon= +glib -g-main-loop -libuv)
Ecore_Con.......: yes (+local-sockets +abstract-sockets systemd-daemon= net-control=none)
Ecore_File......: yes
Ecore_IMF.......: yes (-ibus -scim xim= -wayland)
Ecore_X.........: none ()
Ecore_SDL.......: no
Ecore_Drm.......: no
Ecore_Drm2......: no
Ecore_Wayland...: no
Ecore_Wl2.......: no
IVI-Shell.......: no
Ecore_Buffer....: no ()
Ecore_Cocoa.....: yes
Ecore_Audio.....: yes (-alsa +pulseaudio +sndfile)
Ecore_Avahi.....: yes (-avahi-client)
Ecore_Evas......: yes (+extn +ews -fb -drm -gl-drm -psl1ght +opengl-cocoa -software-sdl -opengl-sdl -wayland-shm -wayland-egl -software-gdi -software-ddraw -software-x11 -opengl-x11 -vnc_server)
Elput...........: no ()
Ector...........: yes
Eeze............: no ()
EPhysics........: yes
Edje............: yes (+physics +multisense -lua-old)
Emotion.........: yes (-v4l2 -xine -gstreamer +gstreamer1 -libvlc generic=static -generic_vlc)
Ethumb..........: yes
Ethumb_Client...: yes
Elua............: yes
Elementary......: yes (-X -FB -PSL1GHT -SDL +Cocoa -Win32 -Wl2 -DRM +quicklaunch)

Tests...........: make check (inexplicitly enabled)
Examples........: make examples (make install-examples)
Documentation...: no
Compilation.....: make (or gmake)

CPPFLAGS......: 
CFLAGS........:  -I/usr/local/opt/openssl/include -fpie
CXXFLAGS......:  -fPIC -DPIC -std=gnu++11
LDFLAGS.......:  -L/usr/local/opt/openssl/lib -fPIC -DPIC -pie -rdynamic
EFLJS_CXXFLAGS:

Installation....: make install (as root if needed, with 'su' or 'sudo')

prefix........: /opt/efler
dbus units....: ${datarootdir}/dbus-1/services

#-------------------------------------------------------------------#

-- ALERT --

#-------------------------------------------------------------------#

Your installation prefix is *NOT* /usr so this means you need

to ensure some files are visible to dbus otherwise services cannot
be started when needed. You will need to do the following:

System-wide installation:

ln -s /opt/efler/share/dbus-1/services/org.enlightenment.Ethumb.service /usr/share/dbus-1/services/org.enlightenment.Ethumb.service

or add "/opt/efler/share" to $XDG_DATA_DIRS

User installation:

ln -s /opt/efler/share/dbus-1/services/org.enlightenment.Ethumb.service ~/.local/share/dbus-1/services/org.enlightenment.Ethumb.service

#-------------------------------------------------------------------#

Not sure if this is something to worry about. This is the first time ive seen this after installing xcode. I am on the latest 10.12.6

ajwillia.ms closed this task as Invalid.Jul 30 2017, 12:45 PM

This is not an issue - for one thing Dbus on OSX is not working so it's not going to cause issues!