Page MenuHomePhabricator

Introduction to EFL new interfaces API
Closed, ResolvedPublic

Description

With EFL new API work, we are trying to provide a more unified view and namespace of EFL. The old weird namespace split should be turning into a cleaner logical one where EFL is the base of it. I am guessing there should be maybe 2 differents introduction. One for those who know about EFL legacy API and one for those who don't.

This should cover major new feature like Eo object model, binding generation, asynchronous by design and MVVM.

zmike added a project: efl.Aug 22 2017, 3:43 PM
cedric added a comment.Oct 2 2017, 3:32 PM

It is also to be noted that we plan and want to support the migration from the old legacy API to the new one with mixing code that are using the old API with code that are using the new API. There should be some explanation about that.

ajwillia.ms closed this task as Resolved.Jan 4 2018, 7:32 AM
ajwillia.ms claimed this task.
ajwillia.ms added a subscriber: ajwillia.ms.
zmike edited projects, added efl: mvvm, efl (efl-1.22); removed efl.Jan 9 2019, 12:10 PM