Page MenuHomePhabricator

Everything closes on focus
Closed, ResolvedPublic

Description

Launching Everything (with keyboard) and starting something without any windows open works fine.

Open a window and position it near the center of the screen so Everything would overlap it, keep pointer away from the window, launch Everything:
Moving pointer from desktop background into Everything works fine.
Moving pointer over the window and then into Everything makes it disappear immediately after launch.

Launching Everything while pointer is over a window makes it disappear immediately.

I'm on Arch, under X11, proprieatary nVidia drivers, updated within the hour, recompiled EFL + Enlightenment + Terminology just after that.
Tried many permutations of window focus and Everything settings without noticing any difference.

EDIT: Forgot to mention Everything behaves pretty much the same if launched from the shelf icon.

TwoD created this task.Aug 10 2017, 1:27 AM
TwoD added a project: enlightenment-git.
TwoD updated the task description. (Show Details)Aug 10 2017, 1:29 AM
zmike added a comment.Aug 10 2017, 5:09 AM

Is this a recent issue?

TwoD added a comment.Aug 10 2017, 7:09 AM

I think so. I have not noticed it until after the update today at work. Will see if I can reproduce at home later today.

I did notice the 2017.2 version of Phpstorm has an issue a with a specific jump-to-file-dialog disappearing as soon as I opened it, but it stayed if I opened another jump-dialog first. That issue is gone after today, but I am getting rendering problems on some dialogs and tooltips, they get squashed together or partially zoomed in, or just random rgb stripes across them. Nothing in other programs though, and I've never been friends with Java...

TwoD added a comment.Aug 10 2017, 11:09 PM

I can confirm this issue began some time since 23 July 10pm as that was the last time I updated my home machine. Only updated EFL, Enlightenment and Terminology at home this morning and now I have the same problem there.

zmike added a comment.Aug 11 2017, 7:51 AM

What version were you on before you updated?

TwoD added a comment.Aug 11 2017, 7:53 AM

.21.99.2679

I somehow suspect https://git.enlightenment.org/core/enlightenment.git/commit/?id=3ee5a0378d2b41313156748ec33202c44c117239 to be related to that ... can you revert that one and check again ?

i reverted the commit. and everything is working correctly now.
no more closes

TwoD added a comment.Aug 13 2017, 5:19 AM

I can confirm reverting 3ee5a0 fixes the issue for me too.

ProhtMeyhet reassigned this task from zmike to raster.Aug 13 2017, 3:09 PM
ProhtMeyhet triaged this task as Showstopper Issues priority.
ProhtMeyhet added subscribers: simotek, raster, ProhtMeyhet.

that's a regression that shouldn't be in a release. @simotek

@raster see 3ee5a0378d2b41313156748ec33202c44c117239

yeah - news. reverting the above3 would revert another fix though... have to figure a way to have both. i've flagged this.

thanks mike! :)

TwoD reopened this task as Open.Aug 16 2017, 4:42 AM
TwoD added a comment.Aug 16 2017, 5:15 AM

Sorry guys but I'm still having issues related to this. Updated my machine and re-built all the packages from here straight out of git a few moments ago.

It's pretty much the same as before, but at least Everything now also stays open if the cursor ends up above it. The pointer refuses to warp to it so I have to position it beforehand.

raster closed this task as Resolved.Aug 16 2017, 6:18 AM

i know. i saw. i already fixed it locally. i have a commit pending a push... it's fixed once i push this... so just be patient. i have other things also queued i need to get to a better point before a push.