Page MenuHomePhabricator

nested shm surfaces broken
Closed, ResolvedPublic

Description

somehow evas_engine_info_set() happens from the display sync event without the wl_shm being in the engine info or being available in the display. should happen every time if you try starting a nested compositor with E_CONF_PROFILE=default

zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:51 AM
zmike edited projects, added efl: display system; removed Restricted Project.Jun 11 2018, 9:13 AM
ManMower lowered the priority of this task from High to Pending on user input.Jun 11 2018, 9:36 AM

I can't reproduce this - does it still happen for you?

zmike closed this task as Resolved.Jun 11 2018, 10:36 AM

We'll say it's fixed for now.