Page MenuHomePhabricator

Firefox 55 display a spinning wheel on all tabs after enlightenment restart or external screen added
Closed, InvalidPublic

Description

The problem is certainly mostly the fault of Firefox, but there is something with enlightenment behaviour which seems to trigger the problem, so opening here to, in the hope someone with internal knowledge of enlightenment can understand what is happening.

So, with firefox 55, each time I restart enlightenment (ctrl+alt+end) or connect/disconnect an external screen (laptop dock/undock), all tabs in firefox but the currently open start to display a spinning wheel in the middle of a grey page.

The problem is discribed here: https://bugzilla.mozilla.org/show_bug.cgi?id=1391216
And there is a scree capture video demonstrating it here: https://bugzilla.mozilla.org/attachment.cgi?id=8900255

I'm on intel i915 xorg, E0.21.9-2 // efl 1.20.2-1, with opengl rendering, tear-free update, assume swapping method: auto.

That bug is going to make me crazy, so any insight for the ff dev would be amazing.

Thanks,

fanf42 created this task.Aug 25 2017, 6:58 AM
ProhtMeyhet triaged this task as Pending on user input priority.Aug 25 2017, 10:39 AM
ProhtMeyhet added a subscriber: ProhtMeyhet.
  • can you try if this happens with software rendering? save your work, changing this setting restarts e. it should be safe, but anyways.
    • Settings -> Look -> Compositor -> Rendering -> Engine
  • are you using a theme that is shipped with e? or custom?
  • what distribution are you on? do you compile yourself from git?
  • can you provide version information on efl and e?

So, with firefox 55, each time I restart enlightenment (ctrl+alt+end)

direct question: why restart e in the first place? any other problems there?

  • can you try if this happens with software rendering? save your work, changing this setting restarts e. it should be safe, but anyways.
    • Settings -> Look -> Compositor -> Rendering -> Engine

Yes, same behavior with software compositor.

  • are you using a theme that is shipped with e? or custom?

Standard theme from e.

  • what distribution are you on? do you compile yourself from git?

I'm on archlinux. I'm using packages from this repository (shared by ajslye on irc): http://www.nulogicsystems.com/public_files/nulogic/x86_64/

  • can you provide version information on efl and e?

I'm not sure what do you need more than "e 0.21.9-2 // efl 1.20.2-1" ?
I have a lattitude E6430 with intel HD 4000 (+discrete nvidia disabled at boot), using default auto config by xorg (sna, etc)
xorg-server 1.19.3-3
mesa 17.1.6-1

So, with firefox 55, each time I restart enlightenment (ctrl+alt+end)

direct question: why restart e in the first place? any other problems there?

The firefox problem happens when I'm (dis)connecting an external monitor (plug/unplug laptop on dock). I remarked that it also happen when I restart E, and it was quicker to reproduce than docking.

It also happens that when I (dis)connect monitor, windows focus/raising is not working correctly (for example, ctrl+tab does not always raise windows), or screen edje stop to switch desktop. Restarting E solve all of that. But this independant from the Firefox problem, which is new an d appeared when I upgraded to firefox 55 (and up).

I don't have error in my .xession-errors appart from the ones already reported (oh, and a new one about module everything... Done #T5944).

Hope it helps... Don't hesitate to ask for more information if needed.

In T5941#96520, @fanf42 wrote:
  • can you provide version information on efl and e?

I'm not sure what do you need more than "e 0.21.9-2 // efl 1.20.2-1" ?
I have a lattitude E6430 with intel HD 4000 (+discrete nvidia disabled at boot), using default auto config by xorg (sna, etc)
xorg-server 1.19.3-3
mesa 17.1.6-1

sorry, standard question. i read over that part in your original statement.

I don't have error in my .xession-errors appart from the ones already reported (oh, and a new one about module everything... Done #T5944).

Hope it helps... Don't hesitate to ask for more information if needed.

can you try running firefox via a terminal and post that output?

can you try to disable "smooth scrolling" in firefox? should be under "Preferences -> Advanced -> Scrolling".

can you try running firefox via a terminal and post that output?

Nothing (appart loads of GTK-Warning about deprecated things in my themes... I have these things since begining of time, and the internet things that 1/ nobody cares, 2/ you can't shut-up GTK for that)

can you try to disable "smooth scrolling" in firefox? should be under "Preferences -> Advanced -> Scrolling".

It was already unchecked. I also unchecked "use auto scrolling" but didn't change anything.

ProhtMeyhet raised the priority of this task from Pending on user input to High.Aug 25 2017, 5:51 PM
In T5941#96537, @fanf42 wrote:

can you try running firefox via a terminal and post that output?

Nothing (appart loads of GTK-Warning about deprecated things in my themes... I have these things since begining of time, and the internet things that 1/ nobody cares, 2/ you can't shut-up GTK for that)

can you try to disable "smooth scrolling" in firefox? should be under "Preferences -> Advanced -> Scrolling".

It was already unchecked. I also unchecked "use auto scrolling" but didn't change anything.

we've covered the basics.

by chance, do you have a java program to test? i sometimes hit something alike this with JDownloader2, but i dont have a test case nor something reproduceable.

anyways, i summon the magic of @zmike :D

ProhtMeyhet lowered the priority of this task from High to Pending on user input.Aug 26 2017, 10:05 AM
In T5941#96520, @fanf42 wrote:
  • what distribution are you on? do you compile yourself from git?

I'm on archlinux. I'm using packages from this repository (shared by ajslye on irc): http://www.nulogicsystems.com/public_files/nulogic/x86_64/

  • can you provide version information on efl and e?

I'm not sure what do you need more than "e 0.21.9-2 // efl 1.20.2-1" ?
I have a lattitude E6430 with intel HD 4000 (+discrete nvidia disabled at boot), using default auto config by xorg (sna, etc)

can you go through the trouble shooting guide on Intel drivers on the archwiki and see if SNA issues, DRI3 issues (or any other) is the case for you?

especially this could be related:

Font and screen corruption in GTK+ applications (missing glyphs after suspend/resume)

Should you experience missing font glyphs in GTK+ applications, the following workaround might help. Edit /etc/environment to add the following line:

/etc/environment

COGL_ATLAS_DEFAULT_BLIT_MODE=framebuffer

https://bugs.freedesktop.org/show_bug.cgi?id=88584

can you go through the trouble shooting guide on Intel drivers on the archwiki and see if SNA issues, DRI3 issues (or any other) is the case for you?

Thanks for the idea, I should have think to that on my own. I even remember the bug about gtk glyph corruption...

But unfortunatly, nothing seems to solve my ff pb. I will report that also on firefox bug, and continue to investigate (it is an UX nightmare right now :/)

For information, during more tests I found that segfault in i915/xorg driver: https://bugs.freedesktop.org/show_bug.cgi?id=102442

Now lets hope there is a common cause and a quick bugfixe...

I need to amend my first report: the switch from "every tabs are ok" to "spinning wheel on them" DOES NOT occures when I'm docking/undocking my laptop (so not related to external monitor) but happen when I restart enlightenment.

So it may be some state that is cleaned by enlightenment restart and interpreted by firefox as "you can't be ready, the desktop is not EVEN initialized - actually, you started before the desktop?" (because really in my case, the grey background / spinning wheel really looks like a "wait for things to be ready" that should not be set at all, and is waiting for something that should be already set)

zmike added a comment.Aug 28 2017, 3:45 AM

I am confused...this happens if you (connect/disconnect a monitor AND restart enlightenment) or (connect/disconnect a monitor OR restart enlightenment)?

Sorry @zmike , (obviously) I wasn't clear. In the first post, I said that the problem happen if I either connect an external monitor or restart E. This is false. I can connect/disconnect monitors without the problem. The problem only happen when I restart (ctrl+alt+end) E and nothing else. The fact that I noticed the problem after connection/disconnection of external monitor is purely incidental (and most likelly happened because I almost also systemactically restart E after such an operation by habits because things in Fri, Aug 25, 11:43 PM comment (ie some focus problems, and lost of windows edge swithching).

So the problem is really linked to something that happen when E restarts. Nothing to do with plugin monitors.
Hope it helps clarify things.

99% sure this is unrelated to enlightenment and is some kind of driver/distro/firefox bug. I use FF55 here and it's been across many, many restarts.

Well, this is good news for E and FF. Not so for me, because it means that there is very little chance someone get to understand what is happening on my side :(

Thanks for the help none the less...

I can reproduce it with the "nouveau" driver and my discrete nvidia video card (and with the intel one disabled on bios to be sure it does not interfere), on a freshly created user with an empty home (and so new firefox profil, new enlightenment config).

So I'm rather confident it is not related to the video driver directly. Where should I look next?

Thanks for any help/ideas

zmike added a comment.Aug 29 2017, 6:21 AM

I don't see why this makes you think it isn't a driver issue? Web browsers make heavy use of the gpu for all rendering, and this is exactly the behavior that I would expect to see if the browser's internal render thread/process stalls due to a driver issue.

Mozilla dev were emitting that hypothesis, so I searched a way to confirm/infirm it. I reported it to because of your comment "some kind of driver/distro/firefox bug." to remove the "driver" part. Now, it only remains distro/firefox (and let be optimistic and add "hardware" to :))

Cheers,

In T5941#96675, @zmike wrote:

99% sure this is unrelated to enlightenment and is some kind of driver/distro/firefox bug. I use FF55 here and it's been across many, many restarts.

the mozilla bug report is from Jiří Slabý (linux kernel dev) who uses openSuse and not enlightenment (KDE IIRC). so yep, probably something in driver/kernel.

I found the problem, it is pure firefox and linked to electrolysis in conjunction with ff55. This one can be closed, and I would like to thank you all for all the help, it provided the necessary push to get me solved that and other problem in efl/enlightenment and a segfault in intel video driver !

fanf42 closed this task as Invalid.Aug 31 2017, 3:33 PM