Page MenuHomePhabricator

E crashes regulary
Closed, InvalidPublic

Description

Happens every 20 - 30 min. in e ...

o is NULL ...

@cedric it started to happen for me since the multiscreen stuff has landed.

#0  0x00007fe10a67048d in evas_object_smart_render_post (eo_obj=0x8000006ec4dcaf66, obj=0x5639e19963c0, type_private_data=0x0) at lib/evas/canvas/evas_object_smart.c:1560
#1  0x00007fe10a6dab9e in evas_render_updates_internal (eo_e=0x800000023cdc1153, make_updates=1 '\001', do_draw=1 '\001', do_async=0 '\000') at lib/evas/canvas/evas_render.c:3571
#2  0x00007fe10a6db659 in evas_render_updates_internal_wait (eo_e=0x800000023cdc1153, make_updates=1 '\001', do_draw=1 '\001') at lib/evas/canvas/evas_render.c:3906
#3  0x00007fe10a6db521 in _evas_canvas_render_updates (eo_e=0x800000023cdc1153, e=0x5639e0933120) at lib/evas/canvas/evas_render.c:3930
#4  0x00007fe10a62deb5 in evas_canvas_render_updates (obj=0x800000023cdc1153) at ../src/lib/evas/canvas/evas_canvas.eo.c:244
#5  0x00007fe10a630b05 in evas_render_updates (obj=0x800000023cdc1153) at ../src/lib/evas/canvas/evas_canvas.eo.c:815
#6  0x00007fe0f27a5c24 in _ecore_evas_x_render (ee=0x5639e092d830) at modules/ecore_evas/engines/x/ecore_evas_x.c:805
#7  0x00007fe10923909c in _ecore_evas_idle_enter (data=0x0) at lib/ecore_evas/ecore_evas.c:284
#8  0x00007fe10b62416a in _ecore_call_task_cb (func=0x7fe109238810 <_ecore_evas_idle_enter>, data=0x0) at ../src/lib/ecore/ecore_private.h:291
#9  0x00007fe10b6240ec in _ecore_factorized_idle_process (data=0x5639e0730850, event=0x7ffc500b1618) at lib/ecore/ecore_idler.c:35
#10 0x00007fe1055622ab in _event_callback_call (obj_id=0x800000000cdc110d, pd=0x5639e072a160, desc=0x7fe10b86a030 <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0, legacy_compare=0 '\000') at lib/eo/eo_base_class.c:1479
#11 0x00007fe10555fd70 in _efl_object_event_callback_call (obj_id=0x800000000cdc110d, pd=0x5639e072a160, desc=0x7fe10b86a030 <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0) at lib/eo/eo_base_class.c:1563
#12 0x00007fe105559e5e in efl_event_callback_call (obj=0x800000000cdc110d, desc=0x7fe10b86a030 <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0) at lib/eo/eo_base_class.c:1566
#13 0x00007fe10b623e70 in _ecore_idle_enterer_call (loop=0x800000000cdc110d) at lib/ecore/ecore_idle_enterer.c:48
#14 0x00007fe10b625285 in _ecore_main_loop_iterate_internal (once_only=0) at lib/ecore/ecore_main.c:2310
#15 0x00007fe10b625666 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1299
#16 0x00005639dedecca7 in main (argc=1, argv=0x7ffc500ea008) at ../src/bin/e_main.c:1088
bu5hm4n created this task.Sep 7 2017, 10:15 AM
zmike reassigned this task from zmike to cedric.Sep 7 2017, 10:24 AM
zmike removed a project: enlightenment-git.
bu5hm4n triaged this task as High priority.Jun 11 2018, 1:56 AM
zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:54 AM

The backtrace seems to indicate a rendering issue, so I tag this as "efl: rendering".

segfaultxavi edited projects, added efl: rendering; removed Restricted Project.Jun 11 2018, 7:52 AM

Is this still happening?

Seems a stretch, but is there any chance you can catch this in valgrind?

Is it related to the screen blanker firing?

I don't think this is still happening.

This is still happening. at least 3-4 times a day.

Is it related to the screen blanker firing?

No its related to small windows opening / closing, I can trigger it quite good with sublime-text-3 and hoverring over a definition, so a window is opened.

I can try to trigger it with valgrind on Monday.

zmike added a comment.Jun 14 2018, 5:51 AM

Definitely needs more info; it seems unlikely that the line numbers there are accurate anymore, and I have no means with which to reproduce...

zmike lowered the priority of this task from High to Pending on user input.Jun 20 2018, 6:13 AM

I cannot reproduce it under valgrind as everything is too slow i guess.

But here is a up to date backtrace:

#0  0x00007f075abcb082 in pause () at /usr/lib/libpthread.so.0
#1  0x0000563c5b744a88 in e_alert_show () at ../src/bin/e_alert.c:43
#2  0x0000563c5b6c850e in _e_crash () at ../src/bin/e_signals.c:81
#3  0x0000563c5b6c84c8 in e_sigseg_act (x=11, info=0x7ffc4f89bf30, data=0x7ffc4f89be00) at ../src/bin/e_signals.c:91
#4  0x00007f075abcba80 in <signal handler called> () at /usr/lib/libpthread.so.0
#5  0x00007f0759276708 in evas_render_updates_internal (eo_e=0x400000008172, make_updates=1 '\001', do_draw=1 '\001', do_async=0 '\000') at lib/evas/canvas/evas_render.c:3595
        ent = 0x563c5e409578
        eo_obj = 0x400000206bfc
        obj = 0x563c5d404e10
        evas = 0x563c5c8b51a0
        e = 0x563c5c8b51a0
        out = 0x0
        ll = 0x0
        l = 0x0
        clean_them = 1 '\001'
        rendering = 1 '\001'
        alpha = 0 '\000'
        r = 0x0
        i = 39
        p1ctx = {e = 0x563c5c8b51a0, active_objects = 0x563c5c8b5298, render_objects = 0x563c5c8b52e0, snapshot_objects = 0x563c5c8b5360, restack_objects = 0x563c5c8b52c0, delete_objects = 0x563c5c8b5278, redraw_all = 0}
        redraw_all = 0
        ao = 0x7f075ae2b0f4 <_eina_string_key_cmp+79>
        render_mode = EVAS_RENDER_MODE_SYNC
        haveup = 1 '\001'
        __FUNCTION__ = "evas_render_updates_internal"
        prepare = 1
#6  0x00007f0759279058 in evas_render_updates_internal_wait (eo_e=0x400000008172, make_updates=1 '\001', do_draw=1 '\001') at lib/evas/canvas/evas_render.c:3942
        ret = 0x0
        l = 0x563c5c8b5110
        out = 0x563c5c8b2308
        e = 0x563c5c8b51a0
#7  0x00007f07592793f2 in _evas_canvas_render_updates (eo_e=0x400000008172, e=0x563c5c8b51a0) at lib/evas/canvas/evas_render.c:3967
        ret = 0x563c5ceffc60
        updates = 0x0
        ru = 0x0
#8  0x00007f075917ccf6 in evas_canvas_render_updates (obj=0x400000008172) at ../src/lib/evas/canvas/evas_canvas.eo.c:212
        _r = 0x7f0757ec488a <_elm_win_pre_render+57>
        ___op = 529
        ___generation = 1
        ___call = {eo_id = 0x400000008172, obj = 0x563c5c8b5110, func = 0x7f075927930a <_evas_canvas_render_updates>, data = 0x563c5c8b51a0, extn1 = 0x4000000d38a1, extn2 = 0x9ae8425601acc000, extn3 = 0x7ffc4f89c7d0, extn4 = 0x7f0742320bf2 <ecore_evas_render_prepare+1377>}
        _func_ = 0x7f075927930a <_evas_canvas_render_updates>
#9  0x00007f075917fcaf in evas_render_updates (obj=0x400000008172) at ../src/lib/evas/canvas/evas_canvas.eo.c:758
#10 0x00007f0742323752 in _ecore_evas_x_render (ee=0x563c5c863d30) at modules/ecore_evas/engines/x/ecore_evas_x.c:805
        updates = 0x7ffc4f8d5360
        rend = 0
        edata = 0x563c5c864000
        render2 = 0
        __FUNCTION__ = "_ecore_evas_x_render"
#11 0x00007f07576c2adc in _ecore_evas_idle_enter (data=0x0) at lib/ecore_evas/ecore_evas.c:280
        change = 0 '\000'
        ee = 0x563c5c863d30
        t1 = 0
        t2 = 0
        rend = 0
#12 0x00007f075a4694d8 in _ecore_call_task_cb (func=0x7f07576c27d9 <_ecore_evas_idle_enter>, data=0x0) at lib/ecore/ecore_private.h:442
#13 0x00007f075a469564 in _ecore_factorized_idle_process (data=0x563c5c6b2530, event=0x7ffc4f89c900) at lib/ecore/ecore_idler.c:35
        idler = 0x563c5c6b2530
#14 0x00007f0753555603 in _event_callback_call (obj_id=0x400000000152, pd=0x563c5c6a57f0, desc=0x7f075a6eb5c0 <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0, legacy_compare=0 '\000') at lib/eo/eo_base_class.c:1595
        it = 0x7f075a710a50 <internal+16>
        cb = 0x563c5c676f10
        lookup = 0x7ffc4f89c940
        saved = {__in_list = {next = 0x0, prev = 0x0, last = 0x7ffc4f89c940}, desc = 0x7f075a6eb5c0 <_EFL_LOOP_EVENT_IDLE_ENTER>, current = 2}
        ev = {object = 0x400000000152, desc = 0x7f075a6eb5c0 <_EFL_LOOP_EVENT_IDLE_ENTER>, info = 0x0}
        idx = 3
        callback_already_stopped = 0 '\000'
        ret = 1 '\001'
        frame = {next = 0x0, idx = 3, inserted_before = 0, generation = 1}
#15 0x00007f0753555b76 in _efl_object_event_callback_call (obj_id=0x400000000152, pd=0x563c5c6a57f0, desc=0x7f075a6eb5c0 <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0) at lib/eo/eo_base_class.c:1679
#16 0x00007f0753555c8a in efl_event_callback_call (obj=0x400000000152, desc=0x7f075a6eb5c0 <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0) at lib/eo/eo_base_class.c:1682
        _r = 0 '\000'
        ___op = 35
        ___generation = 1
        ___call = {eo_id = 0x400000000152, obj = 0x563c5c6a57b0, func = 0x7f0753555b2e <_efl_object_event_callback_call>, data = 0x563c5c6a57f0, extn1 = 0x7ffc4f89ca30, extn2 = 0x7f075a4bf53e <_efl_loop_timer_expired_timers_call+63>, extn3 = 0x41017e6b5d0afafc, extn4 = 0x41
017e6b5d0afafc}
        _func_ = 0x7f0753555b2e <_efl_object_event_callback_call>
#17 0x00007f075a46f6c7 in _ecore_main_loop_iterate_internal (obj=0x400000000152, pd=0x563c5c6a5870, once_only=0) at lib/ecore/ecore_main.c:2338
        next_time = -1
#18 0x00007f075a46c105 in _ecore_main_loop_begin (obj=0x400000000152, pd=0x563c5c6a5870) at lib/ecore/ecore_main.c:1174
#19 0x00007f075a477d78 in _efl_loop_begin (obj=0x400000000152, pd=0x563c5c6a5870) at lib/ecore/efl_loop.c:83
#20 0x00007f075a47b3d3 in efl_loop_begin (obj=0x400000000152) at lib/ecore/efl_loop.eo.c:28
        _r = 0x0
        ___op = 93
        ___generation = 1
        ___call = {eo_id = 0x400000000152, obj = 0x563c5c6a57b0, func = 0x7f075a477d4c <_efl_loop_begin>, data = 0x563c5c6a5870, extn1 = 0x0, extn2 = 0x7f075a4d0a95, extn3 = 0x6362696c2f534547, extn4 = 0x75622079006f6d2e}
        _func_ = 0x7f075a477d4c <_efl_loop_begin>
#21 0x00007f075a46c303 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1247
        __FUNCTION__ = "ecore_main_loop_begin"
#22 0x0000563c5b68c4b1 in main (argc=1, argv=0x7ffc4f8d5368) at ../src/bin/e_main.c:1090
        nostartup = 0 '\000'
        safe_mode = 0 '\000'
        waslocked = 0 '\000'
        strshare = 0x563c5c67694c "/usrL\033\211[\a\177"
        t = 1526221300.0607359
        tstart = 1526221300.0607359
        s = 0x0
        buff = "1526221300.1\000\000\000\000\260dt[<V\000\000`IV[<V\000"
        action = {__sigaction_handler = {sa_handler = 0x563c5b6c85a0 <e_sigabrt_act>, sa_sigaction = 0x563c5b6c85a0 <e_sigabrt_act>}, sa_mask = {__val = {0 <repeats 16 times>}}, sa_flags = -1073741820, sa_restorer = 0x563c5b7464fd <__libc_csu_init+77>}

Reproduced, right now.

Maybe interesting: It only happens when i have 1 screen attached, not if there are two.

That's this line:

eina_evlog("+render_post", eo_e, 0.0, NULL);
netstar closed this task as Invalid.Jul 14 2020, 2:24 AM

Invalid now....