Page MenuHomePhabricator

e wl in x11 stops rendering with internal windows...
Closed, ResolvedPublic

Description

export E_WL_FORCE=x11
export E_START=1
export E_RESTART_OK=1
unset E_START_TIME
/usr/local/bin/enlightenment

then click on "settings". e stops rendering. sits sleeping in select but no more frames come out. software rendering. nvidia host x11 system. same opening up efm.

raster created this task.Sep 7 2017, 8:17 PM
zmike edited projects, added efl; removed enlightenment-git.Sep 8 2017, 7:24 AM
zmike edited subscribers, added: stefan_schmidt; removed: stephenmhouston.

Works fine on EFL 1.20 branch.

zmike reassigned this task from ManMower to cedric.Sep 8 2017, 9:31 AM
zmike triaged this task as Showstopper Issues priority.
zmike added a subscriber: ManMower.

oops meant to use my regression setting for this

Lovely - this started at commit 8c917daa069f0
The one where I made wayland frame callbacks drive animator ticking.

it works fine on drm/gl_drm as well as wayland-on-wayland.

Why the X canvas stops updating, I haven't a clue. If we're dropping into the select loop we're not deadlocked waiting for a frame callback, so ... ?

I'm guessing this is something related to animators and ticking and cedric, and I just happened to be in the wrong place at the wrong time, so I'm happy with the way this ticket is currently assigned. ;)

raster added a comment.Sep 8 2017, 4:53 PM

hahahahahahah. but sure. looks like an efl problem. i just found this yesterday but didn't have time to dig.

zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:51 AM
segfaultxavi edited projects, added efl: display system; removed Restricted Project.Jun 11 2018, 7:22 AM
ManMower closed this task as Resolved.Jun 12 2018, 8:59 AM

I can't reproduce this anymore, and it makes sense that it would be resolved by some of Cedric's work on animators+ticking, but I can't quote a single commit that might've fixed it.

It was almost certainly that we were selecting wayland frame callbacks as the tick source for the X11 canvas, and I know that was fixed.