Page MenuHomePhabricator

Selection in Entry does not work in 1.20
Closed, ResolvedPublic

Description

Open elementary_test, type something in the entry and try to select some text.
Cannot select anything here with 1.20.4. I didn't try with 1.19 but it works with 1.18.
This is a regression (and very annoying) so I thought it should be showstopper but feel free to change it.

Also, selection is working with Efl UI Text.

indefini created this task.Sep 24 2017, 6:16 AM
jpeg reassigned this task from jpeg to herdsman.Sep 24 2017, 10:54 PM
jpeg added subscribers: herdsman, jpeg.

That's a big issue indeed. @herdsman any idea?

jpeg added a comment.EditedSep 25 2017, 1:11 AM

Problem is ELM_DESKTOP_ENTRY. Selection is broken with 0:

ELM_DESKTOP_ENTRY=0 elementary_test -to entry

Selection works with 1:

ELM_DESKTOP_ENTRY=1 elementary_test -to entry
jpeg lowered the priority of this task from Showstopper Issues to High.Sep 25 2017, 1:12 AM
indefini lowered the priority of this task from High to Normal.Oct 22 2017, 7:53 PM

For me the problem was with the entry_select_allow. (added in 1.19 but I didn't notice it because I jumped from 1.18 to 1.20)
The config entry was introduced with ab68723b60e13ef4b248b24d9a362098eb1a5ccc and then raster added the necessary stuff to update the config.

I don't know why but entry_select_allow was still added to the my config as false.

To fix my problem I had to quit enlightenment, erase ~/.elementary and relaunch e.
~/.elementary is created by e, right?
If I just erased it while running e, the config was written with entry_select_allow:false. I guess the config is kept in memory, so even if you erase it, it is overwritten by e.

What happens when you update efl to 1.19 or 1.20 while running e on efl 1.18?
And if you run elementary_config and sets stuff, it's not in conflict with e?

zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:57 AM
bu5hm4n edited projects, added efl: widgets; removed Restricted Project.Jun 11 2018, 9:10 AM
zmike added a subscriber: zmike.

If you are running enlightenment then it will fully manage the config for elm. If you want to guarantee a successful delete of the config, you have to either delete the profile from the enlightenment settings or delete it while not running enlightenment.

Herald closed this task as Resolved. · View Herald TranscriptJan 17 2019, 10:51 AM

Ho Ho Ho! This issue was fixed by Santa!