Page MenuHomePhabricator

elm_code entry area does not fill entire width
Open, NormalPublic

Description

If you have some blank lines in elm_code, in edi, ecrire, etc. Then lose focus on that window for another or the desktop. The gray text entry area does not fill the entire width. There is a gap at the far right, which shows black like the background.

As seen in this screenshot on the right of the EDI window.

Also when you type in text, it seems to fill in that area. However the text cannot enter that same area. In this screenshot, I cannot type another 1 such that the cursor is right on the edge. If I scroll back. the text is on the edge because there is more, but not otherwise. Seems like that is related to the one above. Just the other happens when no text. Most editors will place text/cursor right up to the very edge. Maybe a spacing issue not sure.

Example of another going to edge. The cursor is touching the right edge. Next char moves others over. But no gap like in the 2nd screenshot of EDI.

I cannot seem to replicate locally - are you seeing it with a empty editor or with a particular file or combination of many blank lines etc?

I can replicate in everything except elm_tests. Its there in edi and ecrire. It has nothing to do with the document or amount of lines. It is there with 1 line, just not as visible thus I made more lines so the black would be more visible.

That said if you go to elm tests. In all three the bottom scroll bar moves when it should not. That seems like its trying to expose something on the left. But it is not as visible. Not sure what is going on or if that is even related. But I am not seeing the gap in elm test as i do edi and ecrire. Maybe a UI/box thing.

bu5hm4n triaged this task as Normal priority.Jun 11 2018, 1:04 AM
zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:57 AM
q66 edited projects, added efl: widgets; removed Restricted Project.Jun 11 2018, 7:35 AM

@netstar any idea if this is an issue?