Page MenuHomePhabricator

Refocus last window on desktop switch defaults to last window on screen 0 in a multiscreen setup
Closed, ResolvedPublic

Description

In the Settings -> Windows -> Window Focus -> Miscellaneous section there is an option entitled "Refocus last window on desktop switch" which I assume is supposed to select the last selected window whenever a desktop switch is made (e.g. Alt+F1, Alt+F2 etc). While this works for a single screen environment it does not work for a multi screen environment. In a multiscreen environment (in my case dual screen) this seems to always default to the last selected window on the primary screen even if the last selected window was not on the primary screen.

Reproducability: Always

Environment: Arch Linux updated to 2017-11-02 with the following enlightenment packages

efl-1.20.3-2
enlightenment-0.21.9-1

Steps to reproduce.

  1. Setup a dual screen environment and note the screen that is screen 0
  2. Make sure there are at least two virtual desktops
  3. Open two windows on desktop zero one on each screen. Do the same for the other virtual desktop
  4. Focus the window on the second screen
  5. Switch to other desktop, then back to original desktop. The window will have lost focus and will default to the last focused window on the primary screen.
zmike triaged this task as Pending on user input priority.Nov 2 2017, 4:38 AM

This works fine in my testing and in my daily use. I'll need more info about your focus settings.

This is the full list of settingins in the "Window Focus" advanced settings:

In the focus tab

Focus Policy : Click
New Window Focus : All windows

In the Stacking tab

Autoraise : disabled
Raise when starting to move or resize : on
Raise when reverting focus : on

In the Hints tab

Active Window Hint Policy : Activate on hint

In the Pointer tab

Warping : prevent all forms of pointer warping : on

In the Miscellaneous tab

Always pass click events to programs : on
Click raises the window : on
Click focuses the window : on
Refocus last window on desktop switch : on
Allow focusing of sticky windows when reverting focus : off
Focus last focused window on lost focus : on

zmike added a comment.Nov 6 2017, 6:13 AM

I'm unable to reproduce this on E21 or E22 using the settings that you provided. Can you upload a tarball of your ~/.e directory?

Sorry about the delay i've uploaded a tarball of my .e directory

Okay, I think I've managed to reproduce this, but it looks a bit different than I was expecting? In this case, using your profile if I have a window focused on the current screen and switch desktops, the window on the other screen will now have focus instead of the window on the current screen. It is not restricted to screen 0, it just switches to the last-focused window regardless of which screen it was on. Is this the issue you are describing?

zmike moved this task from Backlog to Active on the enlightenment20 board.Jan 22 2018, 10:11 AM

I've no idea what changed in the latest release of enlightenment but this is fixed now.

Task can be closed

sidewinder16 closed this task as Resolved.Mar 23 2018, 5:01 AM