Page MenuHomePhabricator

.ts file freezes E.
Closed, ResolvedPublic

Description

Download this > http://www.w6rz.net/parkrun1920_23mbps.ts

Double click to open it. > freeze. If it doesn't freeze this way > Rclick on it > Open with... > other application.

ApB created this task.Nov 4 2017, 8:00 AM
zmike added a comment.Nov 6 2017, 5:39 AM

What version of efl are you running?

ApB added a comment.Nov 6 2017, 5:41 AM
In T6319#103934, @zmike wrote:

What version of efl are you running?

this is on the stable system. 1.20.5

zmike added a comment.Nov 6 2017, 5:46 AM

Going to need a backtrace then since it works fine here. This is with the recently added patch which fixed T6049, so perhaps it's the same issue.

ApB added a comment.Nov 6 2017, 5:48 AM

i'll wait until 1.20.6 lands and update the ticket accordingly.

zmike triaged this task as Pending on user input priority.Nov 6 2017, 5:49 AM

I just had a very similar freeze with an mp4 on my desktop. sw or gl rendering. Preview pane shows a generic film reel picture sometimes, and if that happens then the compositor deadlocks as soon as I dismiss the preview. bt shows it's deadlocked in some gst mutex stuff, literally 193 stack frames deep.

I've just noticed I can't reproduce this at all without xwayland loaded, or if I do have it loaded but launch an xterm before trying to deadlock the compositor - so I think this may be in some way related to xwayland.

There's a message on stderr about glamor starting (or failing to in sw mode) around when the broken preview pane pops up.

zmike added a comment.Nov 6 2017, 10:22 AM

I have an xterm running when testing this and it's totally fine. Sounds like bugs.

ApB closed this task as Resolved.Nov 23 2017, 9:26 AM

Fixed in 1.20.6. Probably related to T6049.