Page MenuHomePhabricator

Missing doc for Ecore_Timer
Closed, InvalidPublic

Description

I see on our website, the legacy C Ecore_Timer API is missing some documentation.
It seems that none of the functions present in the generated efl_loop_timer.eo.legacy.h are referenced in the online docs.

This issue may be propagated to other modules (I haven't checked).

jayji created this task.Nov 19 2017, 4:38 AM

I cannot seem to get doxygen to spit this out. The file is parsed (output says so) but never appears in the output.
Perhaps we have a collision of some sort?

OK, the problem is that the docs are generated referencing groups that are not defined - so doxygen is ignoring them.

2 possible fixes:
*) Define the groups
*) Drop the group reference

Not sure which is right until I look into this further.

ajwillia.ms closed this task as Invalid.Dec 15 2017, 8:39 AM

If you wish this page to appear you will need to add something like the following to Ecore_Legacy.h

/* @defgroup Efl_Loop_Timer

  • Some docs about the loop timer group */

The eolian legacy headers add to groups but they don't define them. Look at Evas_Object_Text vs Evas_Text for example.

It is notable that Efl_Loop_Timer is the only eo.legacy header in Ecore - is it supposed to exist?

I don't think there is a bug here so closing the ticket.