Page MenuHomePhabricator

^c on terminology does not work anymore in case of typo in command
Closed, InvalidPublic

Description

^c on terminology does not work anymore in case of typo in command
I am on latest git master and i remembered it working before the update.

just type anything on terminal and then ^c. it does not do anything. ideally it should cancel out the command.

jpeg added a comment.Jan 8 2018, 7:05 PM

Dunno about typo but Ctrl+D doesn't close the terminal and a subsequent Ctrl+C doesn't do anything (though only one ^C will appear).
Note: This is a regression in EFL (or archlinux??) since I didn't update terminology recently. Using zsh.

raster added a comment.Jan 8 2018, 8:43 PM

i haven't updated since saturday ( a few days back) and it all still works for me... ? when did this start happening? is it a change to terminology or efl?

jpeg added a comment.Jan 8 2018, 9:05 PM

Somehow this works again after a new install of efl from git. Very odd!

I've got arch up-to-date, terminology up-to-date, but EFL is few days/weeks old and I don't have this issue.

i have upgraded arch again and i still have this issue. i wonder what went wrong.
will try to find root cause and report here.

i just updated to latest efl and terminology and ctrl+c/d work for me as usual. :( ctrl+c in the middle of typing a command works. in the middle of running a command works. ctrl+d exits the shell (if i have no command typed yet on the prompt as before) ... :/

it works now magically. don't know how and why...
so we can close it.

jpeg closed this task as Invalid.Jan 17 2018, 12:55 AM

Then just close it :D