Page MenuHomePhabricator

terminology loses focus in case of pasting text via Paste button from control.
Closed, ResolvedPublic

Description

Copy text from anywhere and then right click on terminology and click "paste" button. terminology looses focus after paste. you do have to click the terminology window again to get focus.

billiob claimed this task.Jan 10 2018, 2:49 PM
billiob closed this task as Resolved.Feb 11 2018, 2:58 AM

Should be now fixed by 08b5c20a27a8436f39083cd0d72315a376c42d51 and related commits.

Thanks for the fix.

I have noticed a weird behaviour after this.

After i paste text on terminology command line, it does not take any key input until i move window a bit.

singh.amitesh added a comment.EditedFeb 18 2018, 10:42 PM

i am rebuilding efl/e to verify this.

rebuilt efl/e and i could reproduce this.

singh.amitesh reopened this task as Open.Feb 18 2018, 10:49 PM
billiob renamed this task from terminology looses focus in case of pasting text via Paste button from control. to terminology loses focus in case of pasting text via Paste button from control..Feb 25 2018, 8:27 PM
YOhoho added a subscriber: YOhoho.Feb 27 2018, 3:39 AM

I shall try fixing this based on @raster's hints.

[18:44] <_ami_> raster: https://phab.enlightenment.org/T6594 <-- this seems to be related to window focus.
[18:45] <@raster> _ami_: yeah. also right click for control panel
[18:45] <@raster> dismiss it
[18:45] <@raster> and focus is lost
[18:45] <@raster> until u unfocus and focus window again

singh.amitesh closed this task as Resolved.Mar 7 2018, 2:34 AM

This patch does fix this issue. 253680f754f1165ff8b6397d378ecba4af8acc50 -> efl patch.

thanks to @bu5hm4n