Page MenuHomePhabricator

cov-build segfaults duriong nightly build
Closed, ResolvedPublic

Description

Since last week the coverity nightly builds fail due to a segfault when running cov-build.

Beber, did you update things on the system which could be the reason for this? I could think of nothing that would introduce this from the code or from the Jenkins side.

cov-build --dir cov-int make -j6
/srv/build/tmp/jenkins4473727318689615676.sh: line 10: 30649 Segmentation fault (core dumped) cov-build --dir cov-int make -j${PARALLEL_MAKE}

Full log example: https://build.enlightenment.org/view/Nightly/job/nightly_efl_gcc_x86_64_coverity/489/console

stefan_schmidt triaged this task as Normal priority.
beber added a comment.Jan 29 2018, 3:37 PM

I can confirm the issue, doing troubleshooting at the moment

beber closed this task as Resolved.Jan 29 2018, 4:43 PM

Since was due to CONFIG_LEGACY_VSYSCALL_NONE being re-enabled by mistake. This is now fixed on all VMs.