Page MenuHomePhabricator

Systray gadget don't size correctly
Closed, ResolvedPublic

Description

The systray gadget don't resize himself correctly here,
it seems to never resize at all, it always stay at a minimum size and the icons overflow on the right size.

As you can see from the shot above the mega and the dropbox (ugly) icons are overflowing the shelf,
they are also not clickable when outside the shelf.

The same when I place the gadget in a central position:

I'm on latest efl/e git, but the issue is present from a long time.

DaveMDS created this task.Feb 17 2018, 12:43 AM

Some more info after a morning of digging in the systray code:

Probably the issue is related only for images serialized over dbus, all the apps I see in the systray behave in that way.

the code starting point is in e/modules/systray/e_mod_notifier_host.c:106

if (imgdata)
  {
     Evas_Object *o;

     o = evas_object_image_filled_add(evas_object_evas_get(image));
     evas_object_image_alpha_set(o, 1);
     evas_object_image_size_set(o, w, h);
     evas_object_image_data_set(o, imgdata);
     e_icon_image_object_set(image, o);
  }

I tryied lots of combination of min sizes and size hints, but didn't find a way to make it size correctly :(

DaveMDS closed this task as Resolved.Mar 11 2018, 9:02 AM
DaveMDS added a subscriber: raster.