Page MenuHomePhabricator

Wayland session: screenshot doesn't work with efl-git and enlightenment-git
Closed, InvalidPublic

Description

Arch Aur system
https://aur.archlinux.org/packages/efl-git/
https://aur.archlinux.org/packages/enlightenment-git/
Wayland session
Screenshot doesn't work with efl-git-1.20.99.57674 and enlightenment-git-0.22.99.23330
I tried to take screenshots with gimp and/or xfce4-screenshooter.
No picture file generated, only an empty file.
Same bug with software and opengl

ManMower closed this task as Invalid.Feb 21 2018, 11:36 AM
ManMower added a subscriber: ManMower.

Sorry, those tools don't work under wayland, and it's not a bug, it's just... wayland.

Under wayland, only the compositor can perform screenshots - hitting printscreen in E should bring up a screenshot dialog.

Thanks. Sorry for the noise...

Better to have a report of something than to not know there's a problem!