Page MenuHomePhabricator

focus(toolbar): focus tree of toolbar is broken
Closed, ResolvedPublic

Description

reproduction case:

  1. elementary_test -to toolbar

focus key movement is broken. some items can't get focus. moreover, focus is gone after toolbar is resized

YOhoho created this task.Mar 27 2018, 12:14 AM
YOhoho triaged this task as High priority.
bu5hm4n reopened this task as Open.Apr 5 2018, 2:30 PM

More work todo with that.

Open the test, resize the window while a item is focused that gets into the more item.

zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:50 AM
bu5hm4n edited projects, added efl: widgets; removed Restricted Project.Jun 11 2018, 7:04 AM
bu5hm4n edited projects, added Restricted Project; removed efl: widgets, Efl.Ui.Focus.Jun 12 2018, 12:05 AM

It seems that c14ea532eb74 break toolbar visibility
Please check elementary_test -to toolbar8

YOhoho reopened this task as Open.Oct 21 2018, 9:22 PM
  1. Focus is still gone after toolbar is resized(elementary_test -to toolbar (set focus to 'Elementary' item and reduce window size, then focus lost)
  2. Menu can't get focus using arrow key in Toolbar test (elementary_test -to toolbar)
  3. Focus can't escape in toolbar(elementary_test -to focus)
  1. Focus is still gone after toolbar is resized(elementary_test -to toolbar (set focus to 'Elementary' item and reduce window size, then focus lost)

Works here.

  1. Menu can't get focus using arrow key in Toolbar test (elementary_test -to toolbar)

Yes. Menu does not implement anything in regard of focus. Which was always the case. (T6892)

  1. Focus can't escape in toolbar(elementary_test -to focus)

Works here. Are you up to date ?

It seems that c14ea532eb74 break toolbar visibility
Please check elementary_test -to toolbar8

I can check this - but this is likely not caused by this commit. Or can you answer to me why the more item is not displayed, even if we know that the visible flag is false on one item ? :)

Okay - i fixed the toolbar issues. Which is once again absolutly NOT related to focus at all. I don't have a problem with fixing it. However - could we at least keep a little bit of context in tickets ? So focus tickets are not reopened again with issues that are in the toolbar?

  1. Focus is still gone after toolbar is resized(elementary_test -to toolbar (set focus to 'Elementary' item and reduce window size, then focus lost)

Works here.

  1. elementary_test -to toolbar
  2. Click 'Elementay' text item.
  3. reduce widow size until 'More' text item is shown.
  4. Press any arrow key. ( focus lost )
  1. Menu can't get focus using arrow key in Toolbar test (elementary_test -to toolbar)

Yes. Menu does not implement anything in regard of focus. Which was always the case. (T6892)

Oh, I mean 'Menu' text item.

  1. Focus can't escape in toolbar(elementary_test -to focus)

Works here. Are you up to date ?

Yes.

1. elementary_test
2. click 'focus' text button for focus test window.

This works well. But elementary_test -to focus has focus movement issue.
Please check again.

Can you test, with the complete patch set, starting at D7185 down to D7099.

Really, i cannot reproduce this issue ... :( I tryed to reproduce this since 30 min. i cannot. I dont see unreachable items, and i don't see lost focus. I can reach everything, and i can escape the toolbar in elementary_test -to focus.

I don't know right now what else to test ...

For syncing, i have added the branch devs/bu5hm4n/sync to efl, so we make sure to be 100% on the same state. Can you check with this branch ?

bu5hm4n moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Nov 12 2018, 2:20 AM
YOhoho closed this task as Resolved.Nov 20 2018, 7:09 AM