Page MenuHomePhabricator

Elementary test genlist crash, freeze and other bugs
Closed, ResolvedPublic

Description

The crash :
Open elementary_test "genlist focus", click "genlist clear on focus".

The freeze :
Open elementary_test "genlist reusable contents". Click and item and then scroll down.
Here it freezes and I have to kill it.

Some other bugs:
genlist 7 : click the items, they get bigger and then you cannot click then anymore. I don't know if this is normal.
genlist reorder mode : if you reorder something, then the item is left empty. And then it crashes when you close the window. Also there is nothing to tell you, your long press is over.

indefini created this task.Aug 13 2018, 8:31 PM
indefini triaged this task as Showstopper Issues priority.
zmike added a subscriber: zmike.Aug 14 2018, 1:58 PM

It would be great if we had unit tests instead of all these useless elementary_test items...

zmike added a comment.Aug 14 2018, 2:04 PM

Regarding the reorder mode thing, I don't see any issues other than some errors in console which I'm creating a subtask for.

@SanghyeonLee can you verify any of these items?

@SanghyeonLee some help on this for the upcoming 1.22 release would be appreciated

sorry for late actions.

  1. no crash happen by mouse and by key moving in latest efl build.
  2. cannot reproduce by key and mouse. if you still can reproduce issue, please let me know the detail reproduce steps.
  3. genlist 7 : item get bigger because it updated as 2 line label item, but still clickable. this looks normal.
  4. genlist reorder : it looks little bit buggy on reorder moves, but the empty space is normal spec to show what it has to be placed. no crash after reordered and closed.

I think there are no issue left on this task, was already been resolved or was originated by some other issue which is resolved now,
so looks every task is normal behavior for now.
for the case that I missing some reproducing steps, I'll keep it on activate till tomorrow,
and no reply, I'll close it.

thank you.

SanghyeonLee closed this task as Resolved.Mar 25 2019, 9:34 PM