Page MenuHomePhabricator

Shadows on elm apps broken in 1.21.0/0.22.4
Closed, ResolvedPublic

Description

ApB created this task.Aug 27 2018, 11:22 PM
ApB reassigned this task from zmike to ManMower.Sep 7 2018, 2:00 PM
ApB added a comment.Sep 7 2018, 2:20 PM
[23:50] <ManMower> hahahaha
[23:50] <ManMower> so yeah, your gl problem is great
[23:51] <ManMower> and I think I know what it is
[23:51] <ManMower> could take a few days to resolve
[23:51] <ManMower> you're getting an ARGB2101010 visual.  only 2 bits of alpha, so that shadow's gonna suck
[23:53] <ManMower> ApBBB: if you could file a ticket and assign to me, if you haven't already
[23:53] <ManMower> mention ARGB2101010 :)
[23:54] <ManMower> I think the problem is... we're like "so yeah give me a visual with 8 bits of red, 8 bits of green, 8 bits of blue" and mesa's like "yup yup yup you said at least 8 bits, right?  10's good!"
[23:54] <ManMower> and alpha suffers
zmike edited projects, added efl (efl-1.22), efl: rendering, Restricted Project; removed efl (efl-1.21), Restricted Project, enlightenment-git.Jan 14 2019, 11:22 AM
zmike triaged this task as Normal priority.
ManMower removed ManMower as the assignee of this task.Thu, Feb 14, 12:13 PM
ManMower added a subscriber: ManMower.
ApB closed this task as Resolved.Fri, Feb 15, 2:47 AM
ApB claimed this task.

Fixed in git and only need to be backported.