Page MenuHomePhabricator

elm_test gengrid update speed test locks up
Closed, ResolvedPublic

Description

Looks like some kind of focus manager spin happens when trying to run the Gengrid Update Speed test

ManMower created this task.Sep 10 2018, 8:36 AM
zmike edited projects, added Restricted Project, efl (efl-1.22); removed efl.Jan 14 2019, 11:19 AM
zmike triaged this task as Showstopper Issues priority.

@bu5hm4n did you have a chance to reproduce this?

I think we have a bigger underlaying issue, *every* item of the 5000 items is realized, is that really intended ?

Sooo - I manaed to bring down the times. However, its still lagging, the scrolling experience its less than perfect. However, on every group_calculate we walk a list of 5K items just by the design of gengrid, and that is slowing things down *a lot*. Not sure what else we can do here ....

Just tested it. Previously, pressing "Page Down" was so slow Gnome offered to kill the app because it was unresponsive. Now it takes 3 seconds to update.
So performance is still an issue, but at least it does not look like a "lockup".

bu5hm4n closed this task as Resolved.Tue, Mar 26, 12:40 PM

No objections, soooo