Page MenuHomePhabricator

terminology loses focus when exiting settings
Closed, ResolvedPublic

Description

I don't usually change settings, but noticed now everytime I open and close settings, I have to switch windows before terminology gains focus (I can't type in it). I guess efl-1.21.1 is culprit since I havent had this problem before.

Happens with terminology-1.2.1 and -1.1.1.

juippis created this task.Sep 24 2018, 5:00 AM

Still the case with latest terminology-1.3.0. I will try with efl-1.20.7 tomorrow and report back.

Tried switching from libinput to evdev without results btw.

Tried with terminology-1.3.2 and efl-1.20.7. No issues.

With efl 1.21.1, issue still remains with latest terminology. I have no idea :I
What can I do to debug it?

bu5hm4n added a subscriber: bu5hm4n.EditedDec 19 2018, 12:21 AM

Can you check this out with efl-git ? It seems to me that i cannot reproduce this with latest efl and latest terminology. I might forgot to backport a commit into the efl-1.21 release :(

However, it also might be related to your elm_config settings, which would mean you will also see this bug with efl-git ... :)

It does, indeed, seem to be working with efl-git.

So only efl-1.21.1 is faulty in here.

billiob closed this task as Resolved.Mar 6 2019, 6:30 AM
billiob claimed this task.

let's close this one