Page MenuHomePhabricator

Terminology - hotkey problem
Closed, ResolvedPublic

Description

Hi,

I'm trying to add 'Ctrl-Enter' as a hotkey for 'New Tab' in Terminology 1.2.1 built with EFL 1.21.1 on FreeBSD 12BETA1.
I does not work, their are some strange side effects, then Terminology crashes on closing the configuration.
Note, that 'Shift-Enter' does not work neither, 'Ctrl-Shift-Enter' works as expected.

Peter

Peter2121 created this task.Nov 1 2018, 1:03 PM

Both Ctrl-Enter and Shift-Enter work for me.
Could you please try the git version?

tpham3783 added a subscriber: tpham3783.EditedNov 4 2018, 12:08 PM

I've always use Ctrl-Shift-T for creation of new tabs. However, I am able to confirm that terminology wouldn't accept ctrl-enter as hotkeys. below is the exception at the time terminology crashed.

toan@portable64bit:~$ terminology
CRI<26131>:eina_log ../../src/bin/win.c:1762 win_new() unknown log domain -1, original message level was: WRN
terminology: ../../src/bin/options_keys.c:260: _on_shortcut_add: Assertion `ctx->layout == NULL' failed.
Aborted (core dumped)

and backtrace:

terminology: ../../src/bin/options_keys.c:260: _on_shortcut_add: Assertion `ctx->layout == NULL' failed.

Thread 1 "terminology" received signal SIGABRT, Aborted.
0x00007ffff4be8428 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
54      ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) bt
#0  0x00007ffff4be8428 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007ffff4bea02a in __GI_abort () at abort.c:89
#2  0x00007ffff4be0bd7 in __assert_fail_base (fmt=<optimized out>,
    assertion=assertion@entry=0x452aa2 "ctx->layout == NULL",
    file=file@entry=0x452a71 "../../src/bin/options_keys.c",
    line=line@entry=260, function=function@entry=0x452b80 "_on_shortcut_add")
    at assert.c:92
#3  0x00007ffff4be0c82 in __GI___assert_fail (
    assertion=0x452aa2 "ctx->layout == NULL",
    file=0x452a71 "../../src/bin/options_keys.c", line=260,
    function=0x452b80 "_on_shortcut_add") at assert.c:101
#4  0x000000000042086d in ?? ()
#5  0x00007ffff458d3e0 in ?? () from /usr/lib/x86_64-linux-gnu/libeo.so.1
#6  0x00007ffff4589f23 in efl_event_callback_legacy_call ()
   from /usr/lib/x86_64-linux-gnu/libeo.so.1
#7  0x00007ffff4589f23 in efl_event_callback_legacy_call ()
   from /usr/lib/x86_64-linux-gnu/libeo.so.1
#8  0x00007ffff764912f in ?? ()
   from /usr/lib/x86_64-linux-gnu/libelementary.so.1
#9  0x00007ffff76759e5 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libelementary.so.1
#10 0x00007ffff7648b31 in ?? ()
#10 0x00007ffff7648b31 in ?? ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/x86_64-linux-gnu/libelementary.so.1
#11 0x00007ffff77ae066 in elm_obj_widget_event ()
   from /usr/lib/x86_64-linux-gnu/libelementary.so.1
#12 0x00007ffff77bad29 in elm_widget_event_propagate ()
   from /usr/lib/x86_64-linux-gnu/libelementary.so.1
#13 0x00007ffff77c05f5 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libelementary.so.1
#14 0x00007ffff458d31f in ?? () from /usr/lib/x86_64-linux-gnu/libeo.so.1
#15 0x00007ffff4589f23 in efl_event_callback_legacy_call ()
   from /usr/lib/x86_64-linux-gnu/libeo.so.1
#16 0x00007ffff4589f23 in efl_event_callback_legacy_call ()
   from /usr/lib/x86_64-linux-gnu/libeo.so.1
#17 0x00007ffff6a6020b in ?? () from /usr/lib/x86_64-linux-gnu/libevas.so.1
#18 0x00007ffff6a6029b in ?? () from /usr/lib/x86_64-linux-gnu/libevas.so.1
#19 0x00007ffff6a64527 in ?? () from /usr/lib/x86_64-linux-gnu/libevas.so.1
#20 0x00007ffff6a6585e in ?? () from /usr/lib/x86_64-linux-gnu/libevas.so.1
#21 0x00007ffff6a66265 in ?? () from /usr/lib/x86_64-linux-gnu/libevas.so.1
#22 0x00007ffff458d31f in ?? () from /usr/lib/x86_64-linux-gnu/libeo.so.1
#23 0x00007ffff4589f23 in efl_event_callback_legacy_call ()
   from /usr/lib/x86_64-linux-gnu/libeo.so.1
#24 0x00007ffff65a496f in ?? ()
   from /usr/lib/x86_64-linux-gnu/libecore_evas.so.1
#25 0x00007ffff65a5755 in _ecore_evas_input_direct_cb ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/x86_64-linux-gnu/libecore_evas.so.1
#26 0x00007ffff1471cdb in ?? ()
   from /usr/lib/x86_64-linux-gnu/libecore_input_evas.so.1
#27 0x00007ffff67d4ad6 in ?? () from /usr/lib/x86_64-linux-gnu/libecore.so.1
#28 0x00007ffff67dc5d8 in ?? () from /usr/lib/x86_64-linux-gnu/libecore.so.1
#29 0x00007ffff67dca07 in ecore_main_loop_begin ()
   from /usr/lib/x86_64-linux-gnu/libecore.so.1
#30 0x00000000004151f0 in ?? ()
#31 0x000000000040cf2c in ?? ()
#32 0x00007ffff4bd3830 in __libc_start_main (main=0x40cf00, argc=1,
    argv=0x7fffffffd6b8, init=<optimized out>, fini=<optimized out>,
    rtld_fini=<optimized out>, stack_end=0x7fffffffd6a8)
    at ../csu/libc-start.c:291
#33 0x000000000040cf69 in ?? ()

btw @billiob, that was with Terminology-1.2.1, not the git version.

-tp

It seems that the problem is NOT present in GIT version.
It would be nice to see a new release with the fix ;)

You're a lucky guy. I plan on doing it this weekend :)

billiob closed this task as Resolved.Nov 7 2018, 7:59 AM
billiob claimed this task.