Page MenuHomePhabricator

elementary: Hello World example does not render labels
Closed, InvalidPublic

segfaultxavi triaged this task as High priority.
Herald raised the priority of this task from High to Showstopper Issues. · View Herald TranscriptNov 16 2018, 5:22 AM

Thanks for reporting.
I will work on resolving this regression.

Thaaaaaaaaaankyouverymuch!

segfaultxavi reopened this task as Open.Nov 19 2018, 1:16 AM

As of latest master (883058b92bf81784bf51f4cf97066e57367cc81c) I still see the problem. Plus, the Quit button has become quite unresponsive.

Some more details:
I added efl_text_set(_editor, "HELLO"); after building the EFL_UI_TEXT_CLASS object. Now I can see the text, but in the wrong place:
https://www.enlightenment.org/ss/display.php?image=e-5bf27bef907827.28754069.png
Upon the first click on the Quit button, the button is not clicked at all, but the text disappears.
On the second attempt, the button is clicked and the program finishes.
There is a screenful of ERRs on the console involving Zombie objects.
If I do not add the extra call to efl_text_set(), no text is shown, but it takes a variable number of attempts to finally press the Quit button. It seems that it depends on which side of the Quit button you press, suggesting that there is an invisible overlay partially covering the button and intercepting the click events.
Clouseau shows the right hierarchy with every object located in its expected place.

We've discussed this a bit on IRC and on another ticket, so I will add a bit of input here in addition to closing this:

The widget was not intended to handle setting its text and many other operations before the object is "finalized". The issue should be fixed from the user's side (that is, use efl_text_set, and efl_ui_text_scrollable_set after the efl_add call).

This topic is further discussed in https://phab.enlightenment.org/T7477

Thanks for all your input!

herdsman closed this task as Invalid.Nov 26 2018, 5:40 AM

See last comment.