| | |abstract Efl.Canvas.Object | | |├ (P) pointer_mode_by_device | | |├ (P) pointer_mode | | |├ (P) render_op | | |├ (P) clip | | |├ (P) repeat_events | | |├ (P) key_focus | | |├ (P) seat_focus | | |├ (P) precise_is_inside | | |├ (P) propagate_events | | |├ (P) pass_events | | |├ (P) anti_alias | | |├ (P) clipees | | |├ (P) render_parent | | |├ (P) paragraph_direction | | |├ (P) no_render | | |├ (P) coords_inside | | |├ (M) seat_focus_check | | |├ (M) seat_focus_add | | |├ (M) seat_focus_del | | |├ (M) clipees_has | | |├ (M) key_grab | | |├ (M) key_ungrab
- D8273 / rEFL954cdb36561c: efl: apply the stabilzed column of the efl api board
D8040 / rEFLa5e183ad5d1c: efl.canvas.object: clip -> clipper && clipees -> clipped_objects
D8011 / rEFLddb3bd7d210f: efl_canvas_object: remove event_freeze
D8010 / rEFLa25444f0d55e: efl_canvas_object: make is_frame_object internal
D8009 / rEFL422ee8d3233e: efl_canvas_object: get rid of event_animation set/get
D8008 / rEFLf1ad1559b7e1: efl_ui_stack: use direct events instead of event_animation
|Duplicate||singh.amitesh||T5363 Cleanup elm_widget.eo|
I agree is_frame_object() seems internal, as its own docs say.
Furthermore, freeze_events looks awfully similar to event_freeze, which it inherits from Efl.Object.
Are they related? At the very least this should be documented.
If they do the same, kill with fire or hammers.
I do not understand @bu5hm4n 's comment regarding parent.
I think event_animation can be a bit difficult and dangerous, you can see it with the implementation, two special cases for SHOW and HIDE. From a user POV this looks to me like i can go and add an animation to the POSITION_CHANGED event. However, you cannot, since the position will be moved. Not stopped by the animation, so to me this looks only usefull for hide and show. IMO it would be better to "copy" this functionality into efl_ui_stack.c (which is the only user of this). And remove this API and anim_* events from this object... What do you say @Jaehyun_Cho ?
I don't really like the term 'clipee'. This doesn't seem to be a "standard" term used anywhere, and googling it doesn't return useful results.
I think potentially all the seat stuff could just be left as beta for now?
Awesome, clip and clipees form yet another hierarchy. How many do we have?
I agree Google does not seem to know this word, but it seems pretty self-explanatory to me. At most, I would rename them to clipper and clipped_children.
Can't speak about seats, they are still mysterious to me.