| | | |interface Efl.Input.Interface | | | |├ (P) seat_event_filter | | | |├ (E) pointer,move | | | |├ (E) pointer,down | | | |├ (E) pointer,up | | | |├ (E) pointer,cancel | | | |├ (E) pointer,in | | | |├ (E) pointer,out | | | |├ (E) pointer,wheel | | | |├ (E) pointer,axis | | | |├ (E) finger,move | | | |├ (E) finger,down | | | |├ (E) finger,up | | | |├ (E) key,down | | | |├ (E) key,up | | | |├ (E) hold | | | |├ (E) focus,in | | | |├ (E) focus,out
Oh, I thought to meant "conceptual" overlap, sorry.
Yeah, right there, Efl.Ui.Win implements both interfaces, so a user will never know which one is receiving, or to which one he is subscribing.
Is this wrong, though? Do these two events mean the same thing?
I guess this is okay? I haven't really used it as an API too much (though I've worked on it), but I see that we do have some test cases for it so I guess it's probably functional enough?
To be honest, i like the name how it is. The interface here is rather low in the inheritance structure. No API will be named like this the event_prefix is efl_input. Further more, "Efl.Input.Event" implies that it is the content of a event, which is not. Given that, i would pretty much also just leave the name how it is.
Actually I don't mind the name Efl.Input.Event. It's ok but the reason why I suggested is to change the name "Efl.Input.Interface".
To me, it doesn't look common that the word "class" or "interface" is included in a class name or interface name.
I don't stick to the change from "Efl.Input.Interface" to "Efl.Input.Events". I wish we find better name than "Efl.Input.Interface".
Yeah, naming classes Class or interfaces Interface is bad practice. But in this case, it is not named Interface because it is an interface in the OOP sense, it's because this object represents the physical interface between the user and the program, that is, an input device.
There are a lot of names around this concept (input interface, input device, tool, pointer, finger, key, seat, ...) and we have used all of them in one place or another, so this name is complicated :)