| | | |interface Efl.Gfx.Size_Hint | | | |├ (P) hint_aspect | | | |├ (P) hint_max | | | |├ (P) hint_min | | | |├ (P) hint_restricted_min :: set@protected | | | |├ (P) hint_combined_min | | | |├ (P) hint_margin | | | |├ (P) hint_weight | | | |├ (P) hint_align | | | |├ (E) change,size,hints
I do not like the name of this interface. First off, it not only contains size hints, also position (like hint_align). I'd prefer something like Efl.Gfx.Geometry_Hint.
Secondly, Size_Hint suggests that this is a hint, instead of an object accepting hints, but I cannot come up with a better name for that.
Regarding hint_margin, the docs say "margin or padding space" so I have no preference. It was renamed from padding to margin by @jpeg on Wed Jun 8 16:09:38 2016 +0900.