Page MenuHomePhabricator

efl.ui.focus.object
Closed, ResolvedPublic

Description

| |mixin Efl.Ui.Focus.Object
| |├ (P) focus_geometry
| |├ (P) focus :: set@protected
| |├ (P) focus_manager
| |├ (P) focus_parent
| |├ (P) child_focus :: set@protected
| |├ (M) prepare_logical
| |├ (M) prepare_logical_none_recursive :: @protected
| |├ (M) on_focus_update :: @protected
| |├ (E) focus,changed
| |├ (E) manager,changed
| |├ (E) logical,changed
| |├ (E) child_focus,changed
| |├ (E) focus_geometry,changed

Related Objects

StatusAssignedTask
Resolvedzmike
Resolvedzmike
zmike created this task.Jan 8 2019, 11:39 AM
zmike triaged this task as TODO priority.
zmike updated the task description. (Show Details)Jan 9 2019, 6:06 AM

The method naming here seems a bit uninformative?

focus,changed also exists in focus manager.

@zmike which one do you mean ?

RFC: i would rename the event in efl_ui_focus_manager to manager_focus,changed, is that fine to you ?

Yea seems fine on the rename. As for method naming, I meant that prepare_logical is not a super informative method name. What does efl_ui_focus_object_prepare_logical even mean at first glance? Nothing, at least to me...

This function is called before logical movements are performend, this is esp. usefull to set the explict ordering on a node. Hence, prepare logical. Any ideas for a new name ?

  • From the Focus tutorial: "There are 6 commands for Focus navigation: 4 *directional* (Up, Down, Left, Right) and 2 *ordinal* (Previous and Next).". I never liked the word "ordinal", and I am going to change it to "sequential". Therefore, I propose we change the method to sequence_setup or sequence_prepare. The docs should explain that this method is meant to configure the sequence of widgets you get when you navigate through "previous" and "next". The event then could b
  • prepare_logical_none_recursive should be prepare_logical_non_recursive (this is not critical as it is internal).
zmike added a comment.Feb 21 2019, 5:54 AM

setup or prepare sounds good when used with sequence

We had a discussion regarding sequence vs. ordering, and we concluded to stick with ordering, so "setup_ordering" will be likely the way to go agaics.

bu5hm4n moved this task from Backlog to Stabilized on the efl: api board.Feb 22 2019, 5:02 AM
zmike closed this task as Resolved.Mar 11 2019, 10:49 AM
zmike claimed this task.