This should be some other type like array<> or something
This is looking way more intrusive than what I would like at this point. I think we should mark this event and this type as beta for the moment.
This is now @beta, i think we can move this outside the parent task now.
@cedric are we doing anything with this?