Page MenuHomePhabricator

terminology double char width computation breaks mutt
Closed, ResolvedPublic

Description

hello raster,
1cf54d7d breaks the arrows used in mutt to show mail threads hierachy,
especially ((g >= 0x2510) && (g <= 0x2520)) should return EINA_FALSE

jeyzu created this task.Apr 22 2019, 12:15 PM
billiob claimed this task.Apr 22 2019, 1:20 PM
billiob added a subscriber: raster.
billiob closed this task as Resolved.Apr 22 2019, 2:43 PM

the problem is 25AA, 25AB, 25B6, 25C0, 25FB->25FE are emoji...

https://unicode.org/emoji/charts/full-emoji-list.html

keeping up with emoji is a bit of a nightmare TBH... it's all over the place in unicode. i'm not sure how we or shells etc. should handle things like the varying colors of peoples faces and flags and other multi-unicode character sequences... evas doesn't handle these either though (textblock) whilst there it's easier to see how they might be handled...

hmm whilst unicode says they are emoji.. they don't come out as ones according to terminal apps so yeah - keep the entire range out.

jeyzu reopened this task as Open.Apr 24 2019, 3:35 AM
jeyzu added a comment.Apr 24 2019, 3:39 AM

I found another bad range [2630;2637], at least 2630 and 2631 are used by my vim plugin vim-airline ...
so if I execute some thing (:! ./%) when I go back to vim, the status bar is broken.