Code duplication between efl_ui_grid and efl_ui_list is enorm. Is there a reason that not just a second layout function in efl_ui_grid code is written ?
code could be duplicated because they are almost same item-based widget, except the layouting... but I don't know what you mean second layout function.
our plan is support list and grid layout with pack-interface on simple case and MVVM interface on more complex or hugh data handling.
efl_ui_list was written before efl_ui_grid, and I planed to use efl.ui.box internally for simple implements, and it works as well for list layout, but
about grid requirement comes, I couldn't use box anymore so I have to make whole pack interface internally.
I agreed their duplicated code can be merged one common places, except the layout. but its internal change and not that urgent as much as our MVVM delayed :p
so Indeed I agree that this task is about migrate duplicated code on efl_ui_list and grid,
but this is not an urgent task as I think unless it won't change any user-usages and APIs.