Page MenuHomePhabricator

efl.ui.clickable
Open, TODOPublic

Description

mixin Efl.Ui.Clickable @beta
├ (M) press :: @protected
├ (M) unpress :: @protected
├ (M) button_state_reset :: @protected
├ (E) clicked
├ (E) clicked,any
├ (E) pressed
├ (E) unpressed
├ (E) longpressed

Related Objects

StatusAssignedTask
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
Opencedric
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
bu5hm4n created this task.May 3 2019, 10:54 AM
bu5hm4n triaged this task as TODO priority.
bu5hm4n updated the task description. (Show Details)May 18 2019, 12:39 PM
zmike added a comment.Wed, Jun 12, 9:52 AM

It feels a bit weird to split the clicked event between [primary button] and [any button]?

zmike moved this task from Backlog to Evaluating on the efl: api board.Wed, Jun 12, 9:52 AM

Everything else requires you to check the button that you have clicked *every time* you attach to this event. Where our main usage is, that only the primary button is interesting. This is sort of a compromise between usability and smallness.

zmike added a comment.Fri, Jun 14, 7:10 AM

After some thought, I think maybe an improvement on this could be using changed and changed,primary, where the latter indicates the left button has been pressed on a standard mouse configuration. This more definitively handles the case of e.g., left-handed mouse configuration for Xorg/Wayland and we can mention that the primary event will continue to work for right-handed configurations.

I like "primary" more than "any", yep.

It was also brought up that it is confusing to have this in the ui namespace, we should probebly move this to the gfx namespace ...

@zmike changed and changed,primary is more obvious than clicked and clicked,any ???

Hm I suppose it makes sense to move it, but then why not have it be efl.input.clickable to go with efl.input.interface?

I meant clicked and clicked,primary, I'm in too many tickets at once...

efl.input.clickable sounds reasonable, same for the new event names. @woohyun, also okay for you ?

@bu5hm4n

I also feel good with "efl.input.clickable" :)
It should be better than a name with gfx.