Page MenuHomePhabricator

efl.ui.datepicker
Closed, ResolvedPublic

Description

class Efl.Ui.Datepicker @beta
├ (P) min
├ (P) max
├ (P) date
├ (E) changed
  • change the current properties to date_min, date_max (WooHyun)
  • changed -> date,changed (WooHyun)
bu5hm4n created this task.May 3 2019, 11:27 AM
bu5hm4n triaged this task as TODO priority.
CHAN claimed this task.Jul 7 2019, 10:04 PM
Diffusion closed subtask T7562: efl.input.interface as Resolved.

@bu5hm4n @segfaultxavi @zmike @CHAN

How do you think about changing "min -> MinDate" and "max -> MaxDate" ??

(Date -> CurrentDate ? ... I don't think it's nice)

I hope we would take a look at this task together :)

zmike added a comment.Aug 26 2019, 5:17 AM

@bu5hm4n @segfaultxavi @zmike @CHAN

How do you think about changing "min -> MinDate" and "max -> MaxDate" ??

(Date -> CurrentDate ? ... I don't think it's nice)

I hope we would take a look at this task together :)

In the eo this would be date_min date_max date_current ? I think this is an improvement and avoids conflicts.

I approve @zmike's proposal.

woohyun updated the task description. (Show Details)

On a second though, doesn't min_date, max_date and current_date sound better?

In the current API we have about the same number of properties called *_min and min_*, so that's a mess already.
However, we have 3 properties named current_* and none called *_current.

woohyun added a comment.EditedAug 28 2019, 2:54 AM

Ok. then I will change all (*_min + *_max) to (min_*, max_*), if there would be no objection !

But, about current_*

I think just "time" and "date" look better than "current_time" and "current_date".
How do you think about this ?

Normally, in other platforms, SetDate or GetDate is used instead of SetCurrentDate or GetCurrentDate.

zmike added a comment.Aug 28 2019, 6:40 AM

I think we should use the scheme date_min date_max date_current as we do with other similar properties, e.g., in size hints we have restricted_min combined_max since these are "types" of min/max properties.

I trust @zmike's experience. Sorry for D9767.

woohyun added a comment.EditedAug 28 2019, 7:18 PM

@segfaultxavi
No matter :)

@zmike @segfaultxavi
Do we need to add "_current" ?
just "date (for datepicker)" and "time (for timepicker)" look enough. nope ?
In other platforms - there is no use of work "current" for time relating properties.

Plus, if we add "_current", then "size" also needs to be changed to "size_current" ?

zmike added a comment.Aug 29 2019, 6:11 AM

I think just using date and time here is fine...unless this is something which could become a conflict later with something else that has that property?

Let's cross that bridge when we get there :)
If there's no conflict now I'm OK with date and time.

Ok ~

min -> date_min
max -> date_max

I'll change them soon :)

woohyun updated the task description. (Show Details)Aug 30 2019, 1:48 AM

So the API for this one is done?

zmike moved this task from Backlog to Evaluating on the efl: api board.Aug 30 2019, 11:13 AM

What about changed? Does that conflict or not?

In T7869#141314, @zmike wrote:

What about changed? Does that conflict or not?

@zmike

I don't think there would be no conflict -
but we can change it "date,changed" for better understanding.
(Then, we may need to modify other "changed" events properly together)

@segfaultxavi

Do you have any idea on this ?

There is currently no conflict, but I agree we should play it safe and call it date, changed.
Same thing for timepicker, calendar and clock.

BTW, aren't we again trying to fix C#-specific problems (the name collisions) at the EO level?

zmike added a comment.Sep 6 2019, 5:43 AM

There is currently no conflict, but I agree we should play it safe and call it date, changed.
Same thing for timepicker, calendar and clock.

BTW, aren't we again trying to fix C#-specific problems (the name collisions) at the EO level?

Yes, this is a good point...

I guess we could have the C# generator namespace the events automatically or something? cc @lauromoura

The C# generator adds an Event suffix to event names, so they have less chance of colliding with class names, properties or methods.
But two events can still clash if a class inherits two classes emitting events with the same name. In C the namespace is always explicit, but not so in C#.

I changed the event name for efl.ui.datepicker and efl.ui.timepicker first (D9905).

  • efl.ui.calendar : I think this "changed" should be "selected". @bu5hm4n Could you check when you are available ?
  • efl.ui.clock : I think we can change the event name after doing refactoring (T7868)
woohyun updated the task description. (Show Details)Sep 11 2019, 12:31 AM
segfaultxavi updated the task description. (Show Details)Sep 12 2019, 1:34 AM

I think this class is good to go now?

zmike moved this task from Evaluating to Stabilized on the efl: api board.Sep 13 2019, 11:33 AM
zmike closed subtask T7578: efl.ui.view as Resolved.Sep 26 2019, 8:12 AM