| |interface Efl.Ui.Scrollable @beta | |├ (E) scroll,start | |├ (E) scroll | |├ (E) scroll,stop | |├ (E) scroll,up | |├ (E) scroll,down | |├ (E) scroll,left | |├ (E) scroll,right | |├ (E) edge,up | |├ (E) edge,down | |├ (E) edge,left | |├ (E) edge,right | |├ (E) scroll,anim,start | |├ (E) scroll,anim,stop | |├ (E) scroll,drag,start | |├ (E) scroll,drag,stop
|Resolved||None||T7921 enum Efl.Ui.Scroll_Block|
I have to admit that i do not like the name of this interface. It seems it is very connected to scroll_manager and scrollable interactive, what do you think of moving this to use:
- Efl.Ui.Scrollable.User (Efl.Ui.Scrollable)
- Efl.Ui.Scrollable.Interactive (Efl.Ui.Scrollable_Interactive)
- Efl.Ui.Scrollable.Manager (Efl.Ui.Scroll_Manager)
- Efl.Ui.Scrollable.Bar (Efl.Ui.Scrollbar
This would clean things up a little bit, and have related things in one namespace.
How about Efl.Ui.Scroll for the namespace? it's simpler (and shorter).
I understand Efl.Ui.Scroll.User is a widget which uses scroll, but I don't like it. The word User is linked too strongly to the user of the computer.
How about Efl.Ui.Scroll.Scrollable?
Is it ok to remove "Efl.Ui.Scrollable" from "Elm.Interface.Scrollable" -
and declare needed events by itself (instead of using events in "Efl.Ui.Scrollable") ?
After merging, some properties , such as "content_size" or "step_size", are conflicted with different value types.
So, we need to cut off the dependency between old "Efl.Ui.Scrollable_Interactive" and "Elm_Interface_Scrollable" first.
And I want to know what is the proper and best way to do this.