Page MenuHomePhabricator

efl.ui.range_display
Open, TODOPublic

Description

| |interface Efl.Ui.Range_Display @beta
| |โ”œ (P) range_value
| |โ”œ (P) range_limits
  • Move changed min,reached max,reached here, add spec test suite for it.
bu5hm4n created this task.May 3 2019, 11:55 AM
bu5hm4n triaged this task as TODO priority.

Except the wondering why this interface needs to be separated with efl.ui.range_interactive (T7894),
this looks ok for me.

A few interfaces are only implementing efl.ui.range_display, others are implementing efl.ui.range_interactive. If we would not have this split, we would have a lot of unimplemented API.

Woops. I missed the extension relation between two interfaces.
That is, "Efl.Ui.Range_Interactive extends Efl.Ui.Range_Display"

Then, I am ok with current status.

This looks OK to me too. Docs need polishing, as usual.

bu5hm4n moved this task from Backlog to Stabilized on the efl: api board.Jun 18 2019, 2:20 AM
zmike added a comment.Jun 18 2019, 8:59 AM

Do we want to perhaps rename range_min_max to range_limits?

We seem to have far more properties in our API with limit than with min_max, so OK, I buy that.

zmike added a comment.Jun 25 2019, 6:20 AM

This seems okay now

Events should be moved here. lets keep this out of stabilization for now.

bu5hm4n moved this task from Stabilized to Trivial on the efl: api board.Jul 10 2019, 8:14 AM
bu5hm4n updated the task description. (Show Details)Jul 12 2019, 6:15 AM

We might want to check, if setting limits to the same value (min=max) results in the implementor beeing disabled?

woohyun added a comment.EditedJul 13 2019, 1:35 AM

We might want to check, if setting limits to the same value (min=max) results in the implementor beeing disabled?

@bu5hm4n

If you are meaning that "setting min = max" will call efl_ui_widget_disabled_set(obj, EINA_TRUE),
I don't like the way because I cannot imagine what would be happened when efl_ui_widget_enabled_set would be called on that.

I think just making the button (on the efl_ui_slider) not be movable on the slider looks enough.

Okay - lets forget about this idea for now :)

bu5hm4n updated the task description. (Show Details)Jul 31 2019, 1:46 AM

Looks good i think?

Yeah, I think so too.

bu5hm4n moved this task from Trivial to Stabilized on the efl: api board.Jul 31 2019, 5:07 AM