Page MenuHomePhabricator

Terminology (1.4.0) freezes keystroke input after paste - move term window/refocus between windows to unfreeze keystrokes.
Closed, ResolvedPublic

Description

so i've been using ubuntu lts and term 1.2.1 for a long time now (since around T6882 was fixed) without any issues and had a change to arch linux and term 1.4.0...

and this time i got a flashback to T6882 since i had to move the window to unblock input after i pasted into terminology.

to reproduce:
copy a line of text (still unfrozen) and paste it into terminology and it will freeze until you move the window, switch active window, rightclick (leftclick wont work) the window

noticed a thing if your fast you can type one or two letters after paste before it freezes keybord input

some thoughts:
without even looking at the code it feels like the paste command blocks the writing of key inputs,
and that block is unblocked on rightclick/switch (mouse or alt-tab) or move the window.

current system:
EFL 1.22.2
Enlightenment 0.22.4
Terminology 1.4.0

kernel (lts) 4.19.61

when im back home i'll downgrade terminology package and see where it started or if even 1.2.1 is affected, but that wont be until thursday at an earliest.

I think this has been fixed in Terminology 1.5.0 released last week. Could you try it?

for me this seems to be resolved with 1.5.0. thank you!

ProhtMeyhet triaged this task as Pending on user input priority.Jul 31 2019, 6:05 AM
stingray454 added a comment.EditedJul 31 2019, 7:49 AM

alright i'll have a check and see if 1.5.0 fixes it. had missed we got 1.5.0 released though 1.4.0 was the latest my bad.

oh was that the freeze mentioned in the news? will build from git then.

Fixed on terminology 1.5.0

Side notes:
I been facing this problem, on Debian 10 (Buster) together openbox windows manager
To reproduce this issue consistently on Terminology 1.3.2, I followed next steps

Right-click to open the "Controls" menu.  
Select the "Settings" option.
Go back to console
The keyboard does not respond until you change your focus and comeback to terminology

I updated to Terminology 1.5.0 using the experimental packages from Debian, I follower steps on https://wiki.debian.org/DebianExperimental

Thank you for the support

billiob closed this task as Resolved.Sep 15 2019, 2:13 PM
billiob claimed this task.

Thanks @necrifede