Page MenuHomePhabricator

efl_ui_spin_button
Open, TODOPublic

Description

class Efl.Ui.Spin @beta
├ (P) circulate
├ (P) editable
bu5hm4n created this task.Wed, Jul 31, 6:18 AM
bu5hm4n triaged this task as TODO priority.
bu5hm4n added a subtask: T7897: efl.ui.spin.

We have all worked way too much on this widget now and we are all sick of it.
However...

How about wraparound instead of circulate?
Also, editable-text instead of editable? Because the value is always editable (through buttons, keyboard, mouse wheel), but this property is about editing the text.

how about "text_edit" ? I like the other one.

I also like wraparound.

For me, "text_editable" looks a bit better. How do you think about this ?

@bu5hm4n @segfaultxavi

Are you ok with "wraparound" and "text_editable" ?
Then, I'll add action items, and will do by my own soon.

Sounds good to me :)

I'm OK with wraparound but I really think editable_text is better than text_editable (adjective before noun).
Another option is text_is_editable.

@zmike @bu5hm4n @segfaultxavi

Hmm. I am still confused which one is better.
And, I could not find similar names in other platforms, so it is much difficult problem for me.
(Plus, I'm not that good person for naming !!)

  1. efl_ui_spin_button_editable_text_set(obj, EINA_TRUE);
  2. efl_ui_spin_button_text_editable_set(obj, EINA_TRUE);
  3. efl_ui_spin_button_text_is_editable_set(obj, EINA_TRUE);
  1. spinButton.SetEditableText(true); (=> spinButton.EditableText = true;)
  2. spinButton.SetTextEditable(true); (=> spinButton.TextEditable = true;)
  3. spinButton.SetTextIsEditable(true); (=> spinButton.TextIsEditable = true;)

Which one looks better ?
Let's do vote !! :)

hmmmm... I don't like any of them, I am a horrible person :)

  • EditableText looks like this property should be text, not a boolean
  • TextEditable sounds weird in English
  • TextIsEditable sounds best to me, but we have nothing like this in the current API
  • Editable sounds like the opposite of Enabled

Maybe we need to take a step back. How about DirectInput, DirectTextInput, EditableTextEntry, EditableTextBox... ?

direct_text_input +1

@segfaultxavi

You are not such a horrible person :)

I also bet to "direct_text_input".

My last comment! EnableDirectTextInput?

I think its quite clear that a boolean flag is either to turn it on or off, DirectTextInput (direct_text_input) sounds very good to me :)

bu5hm4n moved this task from Backlog to Evaluating on the efl: api board.Thu, Aug 22, 6:45 AM