Page MenuHomePhabricator

[RFE] Don't scroll down on activity unless the scroll at the bottom
Closed, ResolvedPublic

Description

It is often useful to explore the backlog while a command is running in terminal. For example, it could be build happening, while you examine a warning you saw on some of the lines. However, right now any activity in terminal causes the window scroll to fall at the bottom. This should not happen unless the scroll already was at the bottom.

Konsole is known to implement that.

Steps to reproduce

  1. Open Terminology
  2. Execute dmesg so you have lots of text for scrollback
  3. Execute ping localhost
  4. Scroll Terminology up
  5. Wait a few seconds

Expected

Nothing. In particular, scroll stays where it was.

Actual

The window gets automatically scrolled down at the bottom, due to ping adding new text.

Hi-Angel created this task.Aug 20 2019, 5:12 PM
Hi-Angel triaged this task as Wishlist priority.

Could you please check the options under the Behavior settings tab. I think it's called something like "Scroll on new content" and you have to uncheck it.
I'm replying from my phone cause I'm on holidays till early September.

Oh, thanks, I confirm it works.

Any reason it's not default? I don't imagine any downsides to having it enabled, I think usually it's what one wants, because otherwise why would one have scrolled the scrollback in the first place.

FWIW, it's pretty standard behavior for apps where new text may appear any time, such as chat clients, mail clients…

I can send a patch to enable it by default.

billiob closed this task as Resolved.Sep 2 2019, 2:56 PM
billiob claimed this task.

Those are the default.
See in config.c:config_new:

config->jump_on_change = EINA_FALSE;
config->jump_on_keypress = EINA_TRUE;