Page MenuHomePhabricator

Giant memory leak
Closed, ResolvedPublic

Description

After running E in idle for 1h:

==114587== 2,029,460 bytes in 34 blocks are still reachable in loss record 11,736 of 11,738
==114587==    at 0x483877F: malloc (vg_replace_malloc.c:299)
==114587==    by 0x4D41017: _evas_common_rgba_image_surface_mmap (evas_image_main.c:401)
==114587==    by 0x4D419A9: _evas_common_rgba_image_surface_alloc (evas_image_main.c:721)
==114587==    by 0x4D42022: evas_common_image_alpha_create (evas_image_main.c:899)
==114587==    by 0x4D42079: evas_common_image_new (evas_image_main.c:911)
==114587==    by 0x4D44B60: evas_common_rgba_image_scalecache_do_cbs (evas_image_scalecache.c:767)
==114587==    by 0x4CE97F8: eng_image_draw (evas_engine.c:2418)
==114587==    by 0x4DB777C: _draw_image (evas_object_image.c:1792)
==114587==    by 0x4DBA7CD: _evas_image_render (evas_object_image.c:2636)
==114587==    by 0x4DB916D: evas_object_image_render (evas_object_image.c:2279)
==114587==    by 0x4E4368D: evas_render_mapped (evas_render.c:2286)
==114587==    by 0x4E46B23: evas_render_updates_internal_loop (evas_render.c:3098)
==114587==
==114587== 3,295,496 bytes in 40 blocks are still reachable in loss record 11,737 of 11,738
==114587==    at 0x483877F: malloc (vg_replace_malloc.c:299)
==114587==    by 0x4D41017: _evas_common_rgba_image_surface_mmap (evas_image_main.c:401)
==114587==    by 0x4D419A9: _evas_common_rgba_image_surface_alloc (evas_image_main.c:721)
==114587==    by 0x4EEBBD8: _evas_cache_image_entry_surface_alloc__locked (evas_cache_image.c:300)
==114587==    by 0x4EEBC73: _evas_cache_image_entry_surface_alloc (evas_cache_image.c:316)
==114587==    by 0x4EEDB3F: evas_cache_image_surface_alloc (evas_cache_image.c:1068)
==114587==    by 0x4D3F9EB: evas_common_load_rgba_image_data_from_file (evas_image_load.c:462)
==114587==    by 0x4EEE031: evas_cache_image_load_data (evas_cache_image.c:1159)
==114587==    by 0x4D44F62: evas_common_rgba_image_scalecache_do_cbs (evas_image_scalecache.c:906)
==114587==    by 0x4CE97F8: eng_image_draw (evas_engine.c:2418)
==114587==    by 0x4DB777C: _draw_image (evas_object_image.c:1792)
==114587==    by 0x4DBA7CD: _evas_image_render (evas_object_image.c:2636)
==114587==
==114587== 14,822,900 bytes in 16 blocks are still reachable in loss record 11,738 of 11,738
==114587==    at 0x483877F: malloc (vg_replace_malloc.c:299)
==114587==    by 0x4D41017: _evas_common_rgba_image_surface_mmap (evas_image_main.c:401)
==114587==    by 0x4D419A9: _evas_common_rgba_image_surface_alloc (evas_image_main.c:721)
==114587==    by 0x4EEBBD8: _evas_cache_image_entry_surface_alloc__locked (evas_cache_image.c:300)
==114587==    by 0x4EEBC73: _evas_cache_image_entry_surface_alloc (evas_cache_image.c:316)
==114587==    by 0x4EEDB3F: evas_cache_image_surface_alloc (evas_cache_image.c:1068)
==114587==    by 0x4D3F9EB: evas_common_load_rgba_image_data_from_file (evas_image_load.c:462)
==114587==    by 0x4EEE031: evas_cache_image_load_data (evas_cache_image.c:1159)
==114587==    by 0x4CE9771: eng_image_draw (evas_engine.c:2409)
==114587==    by 0x4DB777C: _draw_image (evas_object_image.c:1792)
==114587==    by 0x4DBA7CD: _evas_image_render (evas_object_image.c:2636)
==114587==    by 0x4DB916D: evas_object_image_render (evas_object_image.c:2279)
bu5hm4n created this task.Sep 24 2019, 2:30 AM
bu5hm4n triaged this task as Showstopper Issues priority.
bu5hm4n added a project: efl (efl-1.23).
bu5hm4n added a subscriber: stefan_schmidt.
zmike added a subscriber: zmike.Sep 25 2019, 6:14 AM

I expected this to be from the cursor idle animations, but I created a test app to simulate it and after an hour or so there were no leaks.

cedric added a subscriber: cedric.Sep 25 2019, 1:37 PM

I have been running expedite under massif and only found a leak in the VG part. Nothing that would explain enlightenment leak.

Possible way to track it down is to run enlightenment under Xephyr by passing -massif to enlightenment_start and try to reproduce it that way. It should give deeper meaningful trace and associate it with timing information that could lead to an understanding of what is going on. It might be linked to specific engine configuration like texture mapping stuff.

bu5hm4n closed this task as Resolved.Sep 27 2019, 5:46 AM
bu5hm4n claimed this task.

I think this is fixed by the svg fix you provided. I cannot reproduce this anymore.