Page MenuHomePhabricator

Failed mono testsuite on CI
Closed, ResolvedPublic

Description

I was starting to get the mono bindings working on CI and I run into the following testuite problems:

 RUN         ] TestEldbusConnection.eldbus_connection_new_system

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (eldbus.Connection+Type type) [0x0001f] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusConnection.eldbus_connection_new_system () [0x00000] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusConnection.eldbus_connection_new_system

[ RUN         ] TestEldbusConnection.eldbus_connection_new_starter

[        PASS ] TestEldbusConnection.eldbus_connection_new_starter

[ RUN         ] TestEldbusConnection.eldbus_connection_new_private_session

[        PASS ] TestEldbusConnection.eldbus_connection_new_private_session

[ RUN         ] TestEldbusConnection.eldbus_connection_new_private_system

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (System.IntPtr handle, System.Boolean own) [0x00018] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.GetPrivate (eldbus.Connection+Type type) [0x00006] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusConnection.eldbus_connection_new_private_system () [0x00000] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusConnection.eldbus_connection_new_private_system

[ RUN         ] TestEldbusConnection.eldbus_connection_new_private_starter

[        PASS ] TestEldbusConnection.eldbus_connection_new_private_starter

[ RUN         ] TestEldbusConnection.eldbus_connection_get_unique_name

:1.4

[        PASS ] TestEldbusConnection.eldbus_connection_get_unique_name

[ RUN         ] TestEldbusObject.utc_eldbus_object_send_info_get_p

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (eldbus.Connection+Type type) [0x0001f] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusObject.utc_eldbus_object_send_info_get_p () [0x00006] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusObject.utc_eldbus_object_send_info_get_p

[ RUN         ] TestEldbusObject.utc_eldbus_introspect_p

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (eldbus.Connection+Type type) [0x0001f] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusObject.utc_eldbus_introspect_p () [0x00006] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusObject.utc_eldbus_introspect_p

[ RUN         ] TestEldbusMessage.utc_eldbus_message_iterator_activatable_list_p

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (eldbus.Connection+Type type) [0x0001f] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusMessage.ActivatableList (eldbus.MessageDelegate messageCb) [0x00006] in <14cc5dc6df7941429684d451f2699d58>:0 

  at TestSuite.TestEldbusMessage.utc_eldbus_message_iterator_activatable_list_p () [0x0001e] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusMessage.utc_eldbus_message_iterator_activatable_list_p

[ RUN         ] TestEldbusMessage.utc_eldbus_message_info_data_get_p

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (eldbus.Connection+Type type) [0x0001f] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusMessage.utc_eldbus_message_info_data_get_p () [0x00006] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusMessage.utc_eldbus_message_info_data_get_p

[ RUN         ] TestEldbusMessage.utc_eldbus_message_ref_unref_p

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (eldbus.Connection+Type type) [0x0001f] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusMessage.utc_eldbus_message_ref_unref_p () [0x00000] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusMessage.utc_eldbus_message_ref_unref_p

[ RUN         ] TestEldbusMessage.utc_eldbus_message_iter_next_p

[ ERROR       ] Efl.EflException: Eldbus: null handle

  at Eina.Error.Raise (Eina.Error e) [0x00016] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Common.RaiseNullHandle () [0x0001e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.CheckHandle () [0x00015] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection.InitNew (System.IntPtr handle, System.Boolean own) [0x0000e] in <51be62ad12e541359f5cef464c031964>:0 

  at eldbus.Connection..ctor (eldbus.Connection+Type type) [0x0001f] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestEldbusMessage.ActivatableList (eldbus.MessageDelegate messageCb) [0x00006] in <14cc5dc6df7941429684d451f2699d58>:0 

  at TestSuite.TestEldbusMessage.utc_eldbus_message_iter_next_p () [0x0001e] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestEldbusMessage.utc_eldbus_message_iter_next_p


RUN         ] TestModel.factory_test

[ ERROR       ] System.InvalidOperationException: GCHandle value cannot be zero

  at System.Runtime.InteropServices.GCHandle.op_Explicit (System.IntPtr value) [0x00010] in <76c3dbc427f049499d13c500c18191dc>:0 

  at System.Runtime.InteropServices.GCHandle.FromIntPtr (System.IntPtr value) [0x00000] in <76c3dbc427f049499d13c500c18191dc>:0 

  at Efl.Eo.Globals.WrapperSupervisorPtrToManaged (System.IntPtr wsPtr) [0x00000] in <51be62ad12e541359f5cef464c031964>:0 

  at Efl.Eo.EoWrapper.AddNativeEventHandler (System.String lib, System.String key, Efl.EventCb evtCaller, System.Object evtDelegate) [0x00059] in <51be62ad12e541359f5cef464c031964>:0 

  at Efl.Ui.WidgetFactory.add_PropertyBoundEvent (System.EventHandler`1[TEventArgs] value) [0x00020] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestModel.factory_test () [0x00035] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestModel.factory_test

[ RUN         ] TestParts.basic_part_test

[        PASS ] TestParts.basic_part_test

[ RUN         ] TestParts.inherited_part_test

[        PASS ] TestParts.inherited_part_test

[ RUN         ] TestMVVMParts.mvvm_dynamic_parts

[ ERROR       ] System.InvalidOperationException: Failed to get part text

  at Efl.BindableProperty`1[T].Bind (System.String modelProperty) [0x000b0] in <51be62ad12e541359f5cef464c031964>:0 

  at TestSuite.TestMVVMParts.mvvm_dynamic_parts () [0x00030] in <14cc5dc6df7941429684d451f2699d58>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestMVVMParts.mvvm_dynamic_parts

With the added patch the dbus tests for the mono bindings are fixed, the other two remain.

Couldn't manage to reproduce the issue by building manually (even in a Fedora 30 VM).

Is there any guide on running the CI locally to get access to the build artifacts?

The builds are running in docker containers which you could run on your local machine as well. There is no guide on this (maybe I should write notes down), but here are the rough steps.
To pull the docker image with all deps and the mono runtime installed we use to run the jobs:
docker pull stefanschmidt1/ci-support-files:Fedora30-mono

The docker container does not have the efl source code. On CI that comes from the github notification. Locally you could run it like this from the root of your git checkout.
docker run -ti -v $(pwd):/src stefanschmidt1/ci-support-files:Fedora30-mono

This exposes the local dir as /src in the container and allows you to run locally edited files for testing.

A quick test shows that the mono testsuite is failing but it looks like a different error compared to CI. At least this should give you the same test setup.

Managed to reproduce it. I'll check it ASAP and add these steps to a wiki page.

I did another run after your headless patch was merged and it failed here now:

 RUN         ] TestInheritance.test_inherit_lifetime

finalizer called for parent

Dispose parent

[ ERROR       ] AssertionException: Assertion failed: /src/src/tests/efl_mono/Inheritance.cs:134 (test_inherit_lifetime) Reference not null

  at Test.AssertNull (System.Object reference, System.String msg, System.Int32 line, System.String file, System.String member) [0x00031] in <472a66dcd3ea4043acc6ef9d9114a4bc>:0 

  at TestSuite.TestInheritance.test_inherit_lifetime () [0x00051] in <472a66dcd3ea4043acc6ef9d9114a4bc>:0 

  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke(System.Reflection.MonoMethod,object,object[],System.Exception&)

  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in <76c3dbc427f049499d13c500c18191dc>:0 

[        FAIL ] TestInheritance.test_inherit_lifetime
stefan_schmidt closed this task as Resolved.Nov 27 2019, 4:58 AM

Confirmed fixed