Page MenuHomePhabricator

e_comp - not possible to disable effects
Closed, ResolvedPublic

Description

Hello,
removing the effect setting causes some bugs. Commit : 822680869ff70a0f69dd383e3a810f3f18462dbc
if attached 3 photos.

thierry1970 renamed this task from 822680869ff70a0f69dd383e3a810f3f18462dbc to e_comp - not possible to disable effects.Nov 5 2019, 12:39 AM

The bug on image 3 does not affect patch, I applied the patch upside down and it does not change anything!

The 3rd picture was a bug in the Ordissimo office. Corrected :).

raster added a comment.Nov 6 2019, 9:41 AM

that wifi menu popup... this smells like a compositor matches issue where it doesn't have the right rule to choose the right menu? I can't reproduce that here because I have no idea how that popup is shown, but if you check the compositor advanced settings you can edit the window matches and one of the rules allows a match to match ARGB or not and... if a window is ARGB it should be using a style that doesn't have a dropshadow. is it an override-redirect window? it's certainly an ARGB one which would normally mean no shadow. i need to know what kind of window that is and what its properties are... is there a way i can test and reproduce that here?

the last image - skype... it does the right thing for me - uses the menu match style shadow and I see the menu:

So that is a "works for me".

it's a gadcon popup? have you modified the theme? this is your own module for wifi? how do you get the arrow pointing TO the gadget? normal e gadcon popups don't know the location along the edge they pop up from - they tend to center around their gadget but if at a screen edge they will shift to stay on screen, but the theme doesn't know how to move an arrow if there was one... have you modified this? default theme gadcons are solid thus the default config is to give them a comp style with a shadow... in fact e_gadcon doesn't know about popup theme elements that do have alpha ... i'm looking at the code now. e is doing the right thing here... it knows the popup is solid and thus should have a shadow... :) there is no support to not do this. again - the comp matches decide what style to use so you can change the style chosen for gadcon popups, but e is doing the right thing.

what you have doesn't seem standard and if anything it worked by luck, not by design (check e_gadcon_popup.c - no support to know if the popup is solid or transparent there and the default ones are solid rects so should have gotten shadows).

thierry1970 closed this task as Resolved.Nov 19 2019, 6:38 AM

I understand,
We apply our theme on the popup.
commit 822680869ff70a0f69dd383e3a810f3f18462dbc removes the possibility of not drawing the shadow.
Pity.
I rewrote our popups and deleted the arrows.
I already have enough patches to work correctly on X.
Thank you for watching.

raster added a comment.Dec 4 2019, 1:35 AM

Popups can still use a different comp style - there are already a set (default, everything, flip, fullscreen, menu, none, popup, rotate, still). comp provides "rules" to choose which to apply to what element.

this is a artifact of history when the compositor was separate and added later and thus shadows and such effects had to be done by it redirecting a window. since comp has become a part of e where it isn't optional, this probably should be redesigned as the shadows and so on really should be part of the border or the popup design itself etc. so it's sane/easy to design as it comes together...

but ... you can do what you want to do - the mechanism is there. comp styles exist for this reason. :)