Page MenuHomePhabricator

elm_popup: EPhoto Regression
Closed, InvalidPublic

Description

There is a regression with elementary.

  1. Using default elementary dark theme (default.edj)
  2. Open ephoto
  3. Click Settings Icon

See attached screenshot.

netstar created this task.Apr 1 2020, 12:14 PM
netstar triaged this task as High priority.

confirmed,

but works with the flat theme :)

I added a test to elementary_test:

It reproduces the issue. Works with flat but not default.

  1. elementary_test
  2. popup
  3. popup-scrollable-with-scroller-as-content-and-list

@bu5hm4n Apologies about the test case location. ANyway it reproduces reliably.

zmike added a subscriber: zmike.Apr 13 2020, 7:38 AM

I've spent some time looking into this, and I have questions. Based on the code in the elm_test case, can you explain how and why (in code terms) you are expecting the contents here to have a nonzero size?

zmike lowered the priority of this task from High to Pending on user input.Apr 14 2020, 7:16 AM

Are you saying the code is incorrect? I'm duplicating the behaviour from within ephoto which worked in previous releases.

zmike added a comment.Apr 20 2020, 8:46 AM

It looks to me like you're setting size hints on a box, which would only have ever worked coincidentally at best since a box will overwrite those hints any time it recalculates.

zmike is right. if you want to also have some min hints of your own the trick is:

  1. add an elm table
  2. add an evas rectangle (dont' show it and keep as color 0,0,0,0) in table cell 0,0 1x1
  3. set your custom min size to this rectangle
  4. set 1 child (eg the box) in table cell 0,0 1x1 and show it

the table automatically will calculate the min size of its only cel to be the combined min size of all things in that cell - so your rect and the box. the largest dimensions win. this allows any number of control nodes (rects) so you can have more than 1 subsystem own/control its "node" ()rect) and modify it and table will correctly adjust its min size to the right thing.

netstar closed this task as Invalid.Tue, Jul 14, 2:18 AM

Closing this. Removed the test from elementary, was a miscommunication there..