Page MenuHomePhabricator

imlib2 1.6 slow to determine image loadability
Closed, ResolvedPublic

Description

This issue appears to be a regression, as I cannot reproduce it with 1.5:

■ uname -srvmo
Linux 5.6.14-arch1-1 #1 SMP PREEMPT Wed, 20 May 2020 20:43:19 +0000 x86_64 GNU/Linux
■ LC_ALL=C ls -lh 1994.mkv
-rw-r--r-- 1 userx userx 11G May 17 14:50 1994.mkv
■ LC_ALL=C pacman -Qi imlib2 | grep Version
Version         : 1.5.1-1
■ time imlib2_view 1994.mkv
Image format not available

real    0m0.011s
user    0m0.005s
sys     0m0.006s
■ sudo pacman --noconfirm -U /var/cache/pacman/pkg/imlib2-1.6.1-2-x86_64.pkg.tar.zst &> /dev/null
■ time imlib2_view 1994.mkv
No loadable image

real    0m22.759s
user    0m0.012s
sys     0m4.716s

Thank you for maintaining imlib2. It powers my favorite image viewer (feh).

Row created this task.May 30 2020, 2:28 PM
Row updated the task description. (Show Details)May 30 2020, 2:31 PM
Row added a project: Restricted Project.May 30 2020, 2:33 PM
Row updated the task description. (Show Details)May 30 2020, 6:49 PM
ProhtMeyhet triaged this task as High priority.Oct 8 2020, 9:39 AM
kwo claimed this task.Dec 6 2020, 1:16 AM
kwo closed this task as Resolved.Dec 6 2020, 9:15 AM

Yeah, this was probably caused by the webp loader introduced in 1.6.
Should be fixed in git.
Thanks :)