Page MenuHomePhabricator

Epour not working
Closed, ResolvedPublic

Description

I try to make epour working. I am able to open the console and choose with libtorrent-rasterbar 1.1.14 but the loading of the torrent file fails with malloc_consolidated(): invalid chunk size. With versions of libtorrent-rasterbar 1.2.X or 2.0.X when i start epour it fails with
antoine@yaolinux:~$ epour
Traceback (most recent call last):

File "/usr/bin/epour", line 7, in <module>
  epour = Epour()
File "/usr/lib/python3.8/site-packages/epour/Epour.py", line 81, in __init__
  session.load_state()
File "/usr/lib/python3.8/site-packages/epour/session.py", line 242, in load_state
  settings = self.settings()

AttributeError: 'Session' object has no attribute 'settings'

With the version of libtorrent-rasterbar 1.1.14 to have the tab session working I was obliged to change cgi by html in /usr/lib/python3.8/site-packages/epour/gui/Preference.py

Thanks
Dania5583

Dania5583 created this task.Feb 6 2021, 3:34 AM

I know this package is old but it is in the download directory

Dania5583 added a project: Restricted Project.Feb 6 2021, 12:02 PM

can somebody have a look at this probleme please
Best regards
Dania5583

ProhtMeyhet reassigned this task from Dania5583 to kuuko.Mar 15 2021, 9:29 PM
ProhtMeyhet added a subscriber: DaveMDS.

Could you write an Email to the two Authors listed in the AUTHORS file? They have both not been on here for quite some time and I don't know if they will answer. Sorry there.

Kai Huuhko <kai.huuhko@gmail.com>
Davide Andreoli <dave@gurumeditation.it>

Hello

I have send an e-mail to the two authors. We will see

Best regards

Hello

I have news from Kai Huuko , he said that he has no test unit and that he is busy for the moment. If he find some time he will have a look. Epour is not compatible with libtorrent 2.0 . It confirms what I have found in Repology against libtorrent.

Best regards

Daniel

raster closed this task as Resolved.Sun, May 23, 11:44 AM
Dania5583 reopened this task as Open.Wed, May 26, 7:20 AM
rafspiny added a comment.EditedWed, May 26, 8:05 AM

@raster as far as I can tell, it is fixed.

I also installed it again and run it against libtorrent 1.2.11
For completeness,

@Dania5583 Can you tell more about why you re-opened it? More info?

rafspiny closed this task as Resolved.Thu, May 27, 1:46 PM

@Dania5583 Please, if you think this is not solved, leave some details when re-opening. It is working perfectly fine with libtorrent 1.2.X

I am closing this.

Dania5583 reopened this task as Open.Sat, May 29, 9:21 AM

Hi gentlemen

since the change cgi by htlm the preferences/session tab works but not the Add torrent tab . When i click on it I get this status if i launch epour from a terminal

antoine@yaolinux:/mnt/hd/usr/ports/perso/libtorrent-rasterbar$ epour
Traceback (most recent call last):

File "efl/elementary/object_item.pxi", line 86, in efl.elementary.__init__._object_item_callbackantoine@yaolinux:/mnt/hd/usr/ports/perso/libtorrent-rasterbar$ epour

Traceback (most recent call last):

File "efl/elementary/object_item.pxi", line 86, in efl.elementary.__init__._object_item_callback
File "/usr/lib/python3.8/site-packages/epour/gui/__init__.py", line 123, in <lambda>
  lambda x, y: self.add_torrent())
File "/usr/lib/python3.8/site-packages/epour/gui/__init__.py", line 299, in add_torrent
  TorrentSelector(self.win, self._session, t_uri)
File "/usr/lib/python3.8/site-packages/epour/gui/TorrentSelector.py", line 242, in __init__
  for name, flag in sorted(add_torrent_params_flags_t.names.items()):

AttributeError: type object 'add_torrent_params_flags_t' has no attribute 'names'

File "/usr/lib/python3.8/site-packages/epour/gui/__init__.py", line 123, in <lambda>
  lambda x, y: self.add_torrent())
File "/usr/lib/python3.8/site-packages/epour/gui/__init__.py", line 299, in add_torrent
  TorrentSelector(self.win, self._session, t_uri)
File "/usr/lib/python3.8/site-packages/epour/gui/TorrentSelector.py", line 242, in __init__
  for name, flag in sorted(add_torrent_params_flags_t.names.items()):

AttributeError: type object 'add_torrent_params_flags_t' has no attribute 'names'

i have tried with libtorrent-rasterbar 1.2.11 1.2.13 and 2.0.3 and get the same results, I use boost at the version 1.74.0

Best regards

Daniel

I suppose the problem is on my side . I am not able to compile libtorrent-rasterbar whith the python bindings
Best regards

Daniel

Dania5583 closed this task as Resolved.Sat, May 29, 9:23 AM