Page MenuHomePhabricator

Remember options for desktop & location wrong
Closed, InvalidPublic

Description

Seems like the Remember feature mixes up the Desktop and the Location options:

Desktop: it doesn't remember the desktop on which I used the tool (tried with elicit), in fact I think it does nothing
Location: I assume it means "position in your screen", which works, but it also remembers the Desktop, which is not we want

Thank you

kwo added a comment.Thu, Apr 1, 10:58 PM

Is this about e16?
If no then you probably should assign it to someone else.
If yes then..
Looks to me like its works as it should.
However, you may be confusing "desktops" as in multiple desktops and "screen areas" in virtual desktops.
"Location" remembers the position within the entire virtual desktop area.

Yeah of course e16 :)

Hum... I dont see any "screen areas" option in the remember options

Yeah, so location remembers the position AND the virtual-destkop (so when the app appears, it appears on the virtual-desktop used)

Note: Keep track of changes option is enabled

And so, If I want to remember the virtual-desktop on which it was run (so, the Desktop option, since theres not virtual-desktop one), it doesnt (at least for virtual ones)

kwo added a comment.Fri, Apr 2, 12:46 AM

Not sure exactly what you are asking, but it is not possible to remember the position of a window relative to the current screen (current virtual desktop area), only relative to the full NxM virtual desktop area.
The "Desktop" remembered is which one of the "multiple" desktops.
Multiple desktops are configured in the "Desks" configuration dialog.
Virtual desktops are configured in the "Areas" configuration dialog.
I think things work as you expect if you in "Desks" configure several multiple desktops and in "Areas" configure a 1x1 virtual desktop size.

ProhtMeyhet edited projects, added Restricted Project; removed enlightenment-git.Fri, Apr 2, 7:28 AM
Thanatermesis closed this task as Invalid.Sat, Apr 3, 8:56 AM

Oh!

So virtual desktops are in fact just like a big screen? hum, i didn't know that since all the time using it... but makes sense with the windows shared among the virtual-desktops

Mmmh, then it makes sense and there's no bug, could be nice if "position" just keeps the window in the position of the screen instead of the exact virtual-desktop position (this will mean 3 options, "position", "virtual desktop", "desktop"), but that's not a bug but more like a feature request

Anyways I will close the report