Page MenuHomePhabricator

Maximized (new) windows unable to receive the focus
Closed, ResolvedPublic

Description

I was seeing a strange behaviour in the focus features, making me accidentally closing the wrong window thinking that it was focused, but the previous one was, instead. There's how to reproduce the issue:

  • Settings: all new windows has the focus set
  • In a clean desktop, open a terminal, from it, open the "meld" tool
  • window is focused by default
  • maximize the meld window, and then close it
  • focus is back to the terminal
  • run again meld
  • focus is NOT set to meld now
Thanatermesis updated the task description. (Show Details)
kwo added a comment.Jun 19 2021, 9:02 AM

Which exact e16 version is this?
Please show the configuration (eesh show).

Which exact e16 version is this?

more or less last one: Installed: 1.0.23+git750a973b5e-6buster17 (this includes the last tagged version + the exact git commit reference on which is built)

backgrounds.hiquality = 1
backgrounds.user = 1
backgrounds.no_scan = 0
backgrounds.timeout = 240
compmgr.enable = 1
compmgr.mode = 1
compmgr.shadows.mode = 0
compmgr.shadows.offset_x = 3
compmgr.shadows.offset_y = 5
compmgr.shadows.blur.radius = 8
compmgr.shadows.blur.opacity = 75
compmgr.shadows.sharp.opacity = 30
compmgr.shadows.color = 0
compmgr.use_name_pixmap = 0
compmgr.use_cow = 1
compmgr.fading.enable = 1
compmgr.fading.time = 50
compmgr.override_redirect.mode = 1
compmgr.override_redirect.opacity = 100
desktops.num = 2
desktops.dragdir = 2
desktops.dragbar_width = 0
desktops.dragbar_length = 0
desktops.dragbar_ordering = 1
desktops.desks_wraparound = 0
desktops.slidein = 1
desktops.slidespeed = 11000
desktops.areas_nx = 4
desktops.areas_ny = 3
desktops.areas_wraparound = 0
desktops.edge_flip_mode = 2
desktops.edge_flip_resistance = 25
effects.ripples.enabled = 0
effects.waves.enabled = 0
focus.mode = 1
focus.clickraises = 1
focus.transientsfollowleader = 1
focus.switchfortransientmap = 1
focus.all_new_windows_get_focus = 1
focus.new_windows_get_focus_if_group_focused = 0
focus.new_transients_get_focus = 0
focus.new_transients_get_focus_if_group_focused = 0
focus.raise_on_next = 1
focus.warp_on_next = 0
focus.warp_always = 0
focus.autoraise.enable = 0
focus.autoraise.delay = 500
groups.dflt.iconify = 1
groups.dflt.kill = 0
groups.dflt.move = 1
groups.dflt.raise = 0
groups.dflt.set_border = 1
groups.dflt.stick = 1
groups.dflt.shade = 1
groups.swapmove = 1
iconboxes.anim_time = 250
locale.internal =
locale.exported =
menus.animate = 0
menus.onscreen = 1
menus.warp = 1
menus.show_icons = 1
menus.icon_size = 20
menus.key.left = 0xff51
menus.key.right = 0xff53
menus.key.up = 0xff52
menus.key.down = 0xff54
menus.key.escape = 0xff1b
menus.key.ret = 0xff0d
misc.animation.step = 10
misc.buttons.move_resistance = 10
misc.dialogs.headers = 1
misc.dialogs.button_image = 0
misc.dock.enable = 1
misc.dock.sticky = 1
misc.dock.dirmode = 3
misc.dock.startx = 0
misc.dock.starty = 0
misc.hints.set_xroot_info_on_root_window = 0
misc.log.difftime = 0
misc.log.dest = 0
misc.magwin.zoom_res = 4
misc.movres.mode_move = 0
misc.movres.mode_resize = 0
misc.movres.mode_info = 1
misc.movres.mode_maximize_default = 1
misc.movres.color = 0xff0000
misc.movres.avoid_server_grab = 1
misc.movres.update_while_moving = 0
misc.movres.enable_sync_request = 0
misc.movres.dragbar_nocover = 0
misc.movres.enable_smart_max_hv = 0
misc.movres.maximize_animate = 1
misc.movres.maximize_speed = 6000
misc.opacity.menus = 80
misc.opacity.movres = 50
misc.opacity.tooltips = 90
misc.opacity.focused = 100
misc.opacity.unfocused = 100
misc.place.manual = 0
misc.place.manual_mouse_pointer = 0
misc.place.center_if_desk_full = 0
misc.place.ignore_struts = 0
misc.place.ignore_struts_fullscreen = 1
misc.place.ignore_struts_maximize = 1
misc.place.raise_fullscreen = 0
misc.place.slidein = 0
misc.place.cleanupslide = 1
misc.place.slidemode = 0
misc.place.slidespeedmap = 12000
misc.place.slidespeedcleanup = 8000
misc.session.enable_script = 1
misc.session.script = $EROOT/scripts/session.sh
misc.session.enable_logout_dialog = 1
misc.session.enable_reboot_halt = 1
misc.session.enable_suspend_hibernate = 1
misc.session.cmd_reboot = elive-pm reboot
misc.session.cmd_suspend = elive-pm suspend
misc.session.cmd_hibernate = elive-pm hibernate
misc.session.cmd_lock = elive-pm lock
misc.session.cmd_halt = elive-pm shutdown
misc.shading.animate = 1
misc.shading.speed = 7500
misc.snap.enable = 1
misc.snap.edge_snap_dist = 8
misc.snap.screen_snap_dist = 32
misc.startup.firsttime = 0
misc.startup.animate = 1
misc.testing.argb_internal_objects = 0
misc.testing.argb_internal_clients = 0
misc.testing.argb_clients = 0
misc.testing.argb_clients_inherit_attr = 0
misc.testing.image_cache_size = -1
misc.testing.ximage_cache_count = -1
misc.testing.mask_alpha_threshold = 8
misc.testing.enable_startup_id = 1
misc.testing.use_render_for_scaling = 0
misc.testing.bindings_reload = 1
misc.testing.no_sync_mask = 0
misc.autosave = 1
misc.memory_paranoia = 1
misc.save_under = 1
pagers.enable = 1
pagers.zoom = 1
pagers.title = 1
pagers.hiq = 1
pagers.mode = 2
pagers.scanspeed = 10
pagers.sel_button = 2
pagers.win_button = 1
pagers.menu_button = 3
sound.enable = 0
sound.theme =
sound.mask1 = 0
sound.mask2 = 0
sound.engine =
theme.name = RetroWave
theme.extra_path =
theme.use_theme_font_cfg = 0
theme.use_alt_font_cfg = 0
theme.font_cfg =
tooltips.enable = 0
tooltips.showroottooltip = 1
tooltips.delay = 2000
warplist.enable = 1
warplist.showsticky = 1
warplist.showshaded = 1
warplist.showiconified = 1
warplist.showalldesks = 0
warplist.warpfocused = 1
warplist.raise_on_select = 1
warplist.warp_on_select = 1
warplist.show_shape = 1
warplist.icon_mode = 3

I cannot reproduce the issue.
On my machine the focus shifts nicely to the new window every time.

I do have my focus set to "focus follows mouse clicks".

If I set to default "focus follows mouse sloppily" the focus is caught by the terminal and stays there...which seems to be the issue (or is it actually the wanted behavior?).

kwo added a comment.Jun 23 2021, 10:01 AM

I suspect there is some focus regression from 1.0.22 to 1.0.23 due to my attempts to fix some other focus issues.
I'll dig into it when time permits.

kwo added a comment.Jun 28 2021, 10:47 PM

I have now tied to reproduce this, but unfortunately no luck :(

Try with these steps:

  • open terminal
  • run "meld" from the terminal
  • resize it to half size
  • then press the maximize button (or more specifically, the: wop * ts )
  • close meld
  • run again "meld" from terminal
  • bug: window is not focused

demo video: https://youtu.be/Wp48e6YqQTk

kwo added a comment.Mon, Jul 12, 12:52 PM

Ok, maybe I see it too.
Does the problem go away if you disable "Animate window maximization" (misc.movres.maximize_animate)?

yes :), with the animation disabled I cannot reproduce the issue

kwo added a comment.Thu, Jul 15, 9:48 PM

I think this should now be fixed in git.

Thanatermesis closed this task as Resolved.Thu, Jul 15, 10:33 PM

wohooo! seems like its fixed now :)